WordPress.org

Ready to get started?Download WordPress

Forums

Relevanssi - A Better Search
[resolved] No results, even after deactivating/reactivating (14 posts)

  1. Extrafino
    Member
    Posted 1 year ago #

    I just noticed Relevanssi stopped returning results. It used to work fine, but seemed to stop working after upgrading wp to version 3.4.1 or 3.4.2
    I tried deactivating Relevanssi and rebuilding the index after reactivating. The index builds, but the search page does not return any results.
    I have a call to query_posts on the search results page, but removing it does not change anything.
    Deactivating Relevanssi shows normal wp search results.
    Any ideas?

    http://wordpress.org/extend/plugins/relevanssi/

  2. sedemik
    Member
    Posted 1 year ago #

    I have same problem too. Not working anymore.

  3. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    Hard to say. I can say it's not the 3.4.2 upgrade, Relevanssi does work with 3.4.2. Have you upgraded something else?

  4. fisnollo
    Member
    Posted 1 year ago #

    Same problem here. Index shows terms, but any search returns no results.

  5. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    Is anybody willing to give me admin access to their site? I'd like to take a look around to see if I can figure out what's wrong. It's very hard to fix something I can't reproduce on any of my sites.

  6. sedemik
    Member
    Posted 1 year ago #

    I works for me again.

    When I only deactivated and activated plugin it didn't do nothing. So, I deactivated it and deleted it. Then I installed, made my own setups, build the index and continued indexing.

  7. Extrafino
    Member
    Posted 1 year ago #

    I tried deleting and reinstallung, still same for me. With Relevanssi activated, I get no search results

  8. rubious
    Member
    Posted 1 year ago #

    I have the same problem, and it won't fix by deactivating or deleting.

    If it's any help, this is the MySQL error showing on the search results page:

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3]
    SELECT *, title + content + comment + tag + link + author + category + excerpt + taxonomy + customfield + mysqlcolumn AS tf FROM wp_relevanssi WHERE term = 'exhibition' AND ((doc IN (SELECT DISTINCT(ID) FROM wp_posts WHERE post_type IN ('post','page','attachment','exhibition','sponsor'))) OR (doc = -1)) ORDER BY tf DESC LIMIT
    
    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3]
    SELECT *, title + content + comment + tag + link + author + category + excerpt + taxonomy + customfield + mysqlcolumn AS tf FROM wp_relevanssi WHERE (term LIKE '%exhibition' OR term LIKE 'exhibition%') AND ((doc IN (SELECT DISTINCT(ID) FROM wp_posts WHERE post_type IN ('post','page','attachment','exhibition','sponsor'))) OR (doc = -1)) ORDER BY tf DESC LIMIT
  9. Destructiq
    Member
    Posted 1 year ago #

    sampe problem here: No post results, but shows amount of search results

  10. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, the MySQL code posted by rubious helped me figure this out.

    You probably have "Limit searches" enabled and "Limit" is empty. Put a value in "Limit" (say, 200), and the search works.

  11. Extrafino
    Member
    Posted 1 year ago #

    For me, the problem remains. Limit or no limit, still the same with WP 3.4.2 and Relevanssi 3.0.5 gives no search results.

  12. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    Can you give me admin access so I can take a look at your site? Otherwise, there's very little I can do to help. My email is mikko @ mikkosaari.fi.

  13. Extrafino
    Member
    Posted 1 year ago #

    The last update to the RoleScoper-Plugin solved this problem for me.

  14. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    Ah, had you mentioned you were running Role-Scoper, I'd fixed this a month ago. Glad to hear it works now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.