WordPress.org

Ready to get started?Download WordPress

Forums

Relevanssi - A Better Search
[resolved] Exclude these posts/pages from search problem (6 posts)

  1. nhowarth
    Member
    Posted 3 years ago #

    I have been using Relevanssi for some time now and it has been working fine.

    But a couple of days ago I added a new page to by blog. - and added its ID to "Exclude these posts/pages from search" and rebuilt the index. (I also have the Indexing Options to 'just posts').

    However, the page appears in the search results.

    I have emptied my main cache, I use Quick Cache, and set the caching expiry in Relevansii to 1 second.

    Any thoughts what may be casing this?

    Thanks,

    Nigel

  2. Mikko Saari
    Member
    Plugin Author

    Posted 3 years ago #

    Does the page appear if you disable Relevanssi caching completely?

    In any case, if you have "Just posts" set, the page shouldn't be in the index in the first place. Sounds like there's bug somewhere.

  3. Mikko Saari
    Member
    Plugin Author

    Posted 3 years ago #

    Quick initial testing on my system says the "Just posts" works and drops the pages off the index. Excluding pages with the exclusion option works as well.

  4. nhowarth
    Member
    Posted 3 years ago #

    Hi msaari - thanks for getting back to me so quickly.

    I've turned off the Relevanssi cache, saved the setting and rebuilt the index - and cleared my site cache, but the post still appears in the search results.

    In fact I have previously included other page IDs in "Exclude these posts/pages from search" to prevent them from displaying in search results - even though I have "Just posts" set.

  5. Mikko Saari
    Member
    Plugin Author

    Posted 3 years ago #

    I'm sorry, but I have no idea what could cause the pages to be indexed even though "just posts" is set. They shouldn't be, and on my sites this setting works just as it should.

  6. nhowarth
    Member
    Posted 3 years ago #

    Hi msaari - I found the problem - it was my fault.

    I was trying to limit the number of search results appearing on a page to 10 and included <?php query_posts($query_string."&showposts=10") ?> in search.php.

    This had the effect of completely ignoring Relevanssi's search results. Now that I have removed the statement, everything is working OK.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic