WordPress.org

Ready to get started?Download WordPress

Forums

Relevanssi - A Better Search
[resolved] Empty index in new version (4 posts)

  1. ryanmberry
    Member
    Posted 1 year ago #

    Hi,

    As with some other people on this forum, I've updated WP to 3.4.2 and Relevanssi from 2.9.x to the latest version.

    The index is empty even though it says that indexing has been successfully completed. I've deactivated and also reinstalled but it's still the same.

    Limit searches is ticked and limited to 500 and it is indexing posts and pages. Any other ideas to help troubleshoot this?

    Thanks!

    http://wordpress.org/extend/plugins/relevanssi/

  2. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    This happened to me just couple of days ago and a closer look revealed that the update had removed the old Relevanssi database, but didn't create a new one. Relevanssi can't index without a table, so I just created the table manually and then it worked.

    If creating the table manually in phpMyAdmin (copy the scheme from lib/init.php) sounds complicated, a clean install should do the trick.

    If reinstalling from scratch doesn't help, then I'm clueless. I'd still check the database to see if the wp_relevanssi table is present, because that'll cause a problem like this.

  3. ryanmberry
    Member
    Posted 1 year ago #

    Hi,

    Thanks for the reply. Relevanssi hadn't created the table (and a clean install didn't create it either) and doing it manually seemed a little too much like hard work :) But it's ok, I've found the exact cause of the problem now and fixed it - maybe this will be helpful for others too.

    In my wpconfig, I had this:

    define('DB_CHARSET', 'utf8_general_ci');

    which is not compatible with the plugin's table creation. Changing it to utf8 fixed the problem and Relevanssi has successfully created all of the tables that it needs. Perfect!

  4. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks, that's good to know. I was thinking along these lines myself, and it's good to get a confirmation. I'll fix this in the next version to make sure it works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic