WordPress.org

Ready to get started?Download WordPress

Forums

Relevanssi - A Better Search
Certain words return blank white page (2 posts)

  1. fifeweb
    Member
    Posted 1 year ago #

    Thanks for creating Relevanssi, it's a great plugin.

    I've just installed and configured Relevanssi and it works great, except that when I search for certain words ("hall"), I get a completely blank page.

    Here are some queries and their results:

    "hall": white page
    "city hall": white page
    "hall city": correct search results
    "city hall directions": correct search results
    "halt": correct search results

    The Relevanssi log shows 41 hits for the query "hall".

    When the search fails, my http access log shows a status code of 200 with 0 bytes sent for that query. MySQL(5.1.36) and PHP(5.3.0) both show no errors in their logs.

    My indexes have built correctly. I am only indexing pages and the number of pages indexed is the same as the number of pages in my site (267). Shortcode expansion is off.

    Based on threads of other people with similar problems, I have turned off fuzzy search and the problem persists.

    If I add the word ("hall") to stopwords, then queries for that word show no results rather than the blank page, but the word is an important word that needs to be searchable.

    I found no other query_posts loops on the search results page. I am using the theme "Basic" by "Themify"

    Being able to search for this word is important, but even more important is knowing that visitors to my site won't unexpectedly be getting blank pages. Any help would be appreciated.

    Thank you.

    http://wordpress.org/extend/plugins/relevanssi/

  2. Mikko Saari
    Member
    Plugin Author

    Posted 1 year ago #

    Curious problem. Mostly it makes sense, but why "hall city" works when "city hall" doesn't is strange, as those two queries should be pretty much the same for Relevanssi.

    What does your error log say when you do a failing search?

    Try enabling the "Limit searches" option and set the limit to 100 first and 50 then, if that doesn't help.

    Sounds like a some kind of memory/performance issue, except 267 posts is very small number to have memory issues.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic