WordPress.org

Ready to get started?Download WordPress

Forums

Registered Users Only
[resolved] plugin redirects to login for in loop (4 posts)

  1. maorb
    Member
    Posted 2 years ago #

    I tried this plugin and it seems to have a bug.
    After I log in to the admin panel, and I try to navigate in the admin menu, then I am being redirected to the login screen again and a parameter is being added to the url - reauth=1

    Then I log in again, and try to navigate in the admin panel, and again I'm being redirected to login screen with reauth=1.

    With this plugin turned off - this is no happening, so this plugin for sure makes the issue.

    Is there a fix for this?
    Thanks

    http://wordpress.org/extend/plugins/registered-users-only/

  2. Alex Mills (Viper007Bond)
    Moderator
    Plugin Author

    Posted 2 years ago #

    Odd. My plugin uses core functionality to see if you're logged in or not and to do the redirect.

    Try clearing your cookies and/or using the "Remember Me" checkbox.

  3. maorb
    Member
    Posted 2 years ago #

    Thanks @Alex. Yea, I know it's odd. I've already tried clear all cookies, close session/restart browsers, delete all browser's history , temp files and session with cCleaner and nothing helped. I also deactivated all plugins and tried to switch back to default theme, and still the same.
    Of course I've also used the "Remember Me" checkbox.
    Finally, I had no choice since I needed it to work in that same moment yesterday, and after spending an hour or so I gave up and installed another plugin I've found (DW Members Only) which is working fine.

  4. Alex Mills (Viper007Bond)
    Moderator
    Plugin Author

    Posted 2 years ago #

    Cool. Sorry my plugin didn't work out for you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic