WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Register Plus] WP 2.8 - Does Reg. Plus work? (6 posts)

  1. kyleinwuhan
    Member
    Posted 5 years ago #

    Has anyone tried using Register Plus yet, after upgrading to WP 2.8? I may wait until it's officially released before I upgrade. I was just curious if RP worked or not.

  2. halinagold
    Member
    Posted 5 years ago #

    I just installed it on 2.8.1 and it looks OK.

    I see 3 bugs but am not aware if it's 2.8.1. bugs or just bugs :-)

    1. With a html email to the new user, slashes are being added before special characters.
    2. My a href tags don't work (I wonder it this is the same problem as the above"

    3. With the admin email, %invitecode% returns a blank field

    Any ideas?

    Thanks -

    Halina

  3. nyliferocks
    Member
    Posted 4 years ago #

    I just tried it with 2.8.1 and my sign up page still shows the same as it always has. The only thing working is the customized logo which I had to manually upload because the regular upload path gave me an error.

  4. anmari
    Member
    Posted 4 years ago #

    Just loaded it and it seems if you want to add a custom field in user editing that the wordpress bug 9640
    http://core.trac.wordpress.org/ticket/9640

    is still causing a problem in 2.8.2 even though the patch has been around for ages.

    This is a wordpress problem but does affect register plus unfortunately.

  5. Anthony Butler
    Member
    Posted 4 years ago #

    Problems with password strength meter and CAPTCHA in 2.8.3.

  6. spacechampion
    Member
    Posted 4 years ago #

    I get the slashes added to new registration to user email and admin email too.

    I fixed it by adding the php function stripslashes.

    Line 900: change <?php echo $regplus['msg'];?> to <?php echo stripslashes($regplus['msg']);?>

    Line 941: change ?php echo $regplus['adminmsg'];?> to ?php echo stripslashes($regplus['adminmsg']);?>

    In those instance, the custom msg and adminmsg are read from the database, which if you have characters like single or double quotes anywhere will have the slashes before them. The two above lines strip out the slashes to display the correct custom messages every time you want to edit the settings.

    In addition to the settings page, you have to strip out the slashes before sending the messages.

    Line 1817: change $regplus['adminmsg'] to stripslashes($regplus['adminmsg'])

    Line 1879: change $regplus['msg'] to stripslashes($regplus['msg'])

    I hope that helps.

Topic Closed

This topic has been closed to new replies.

About this Topic