WordPress.org

Ready to get started?Download WordPress

Forums

Register Plus Redux
[resolved] Logo and other issues (28 posts)

  1. khaos68
    Member
    Posted 3 years ago #

    Logo didn't show even after disabling the "Organize my uploads into month- and year-based folders" option.
    And talking about this option the "Miscellaneus Settings" link is broken.

  2. craigbic
    Member
    Posted 3 years ago #

    I have upgraded to Register Plus Redux 3.6.6 and it still will not accept a custom logo even though I have gone into Media settings and unchecked the "Organize my uploads into month- and year-based folders" option. Also, now when I try to go into my installed plugins list, it is now broken and shows up as completely blank. All other admin sections seem to work fine, just not plugins. I have to use FTP to remove Register-Plus_redux directory in the wp-content/plugins folder of my blog to be able to get back into my plugins list.

  3. radiok
    Member
    Plugin Author

    Posted 3 years ago #

    I'm working on the custom logo issue now, I actually want to use the same framework posts use to insert images, I'm just not sure that makes logical sense... Regardless, I will have this remedied soon.

    craigbic, are using WordPress 3.0.1? And/or WordPress MU? I can't see what Redux would do to cause that problem but that's pretty serious.

  4. craigbic
    Member
    Posted 3 years ago #

    craigbic, are using WordPress 3.0.1? And/or WordPress MU? I can't see what Redux would do to cause that problem but that's pretty serious.

    Yes, I am using WP 3.0.1 and no not WP MU.

  5. radiok
    Member
    Plugin Author

    Posted 3 years ago #

    khaos68, I fixed the custom logo in 3.6.7. Let me know how that works for you.

  6. saury316
    Member
    Posted 3 years ago #

    logo issue still exists. sort of.
    basically, it will load the logo the first time, and show the custom logo. but if I hit save again, it erases the record and goes back to the standard logo.

    is there a hidden field that isn't being set correctly when it shows the custom logo on the settings page that needs to be set? Can't think of any other reason why it would be resetting that field.

    On a related note, I am seeing issues with the passoword strength indicator (it doesn't dynamically update).
    On 3.6.7 with 3.0.1 on Chrome.

  7. radiok
    Member
    Plugin Author

    Posted 3 years ago #

    saury316, I'm working on the password strength indicator, that changed some since 2008 when skullbit abandoned register plus, so I'm rewriting that from scratch. In regard to the custom logo resetting, that's really interesting, I think I have an idea what's happening, it's a bit surprising, but interesting. I'll fix that up.

  8. radiok
    Member
    Plugin Author

    Posted 3 years ago #

    saury316, I fixed the custom logo saving thing, I also made it so you can point the logo to any URL, not necessarily a picture you uploaded from Redux's settings. That was a feature request from Reg Plus's forum. Let me know if that works.

  9. craigbic
    Member
    Posted 3 years ago #

    radiok,

    It looks like the custom logo issue is resolved but once I activate your plugin, I can no longer go back to my admin plugins list - it shows up blank and I have to use an FTP client to remove the plugin before I can go back. I have WP 3.0.1 and not WP MU. Only seems to affect this particular page of the admin (plugins.php). I can do Add New and Editor just not Plugins.

  10. radiok
    Member
    Plugin Author

    Posted 3 years ago #

    craigbic, I am so confounded, I can't imagine what's causing this to happen, it definitely isn't happening on my site. Can I ask what settings you are using in Redux? Really I only need to know what you have enabled, I want to use the same settings and see if I can recreate this problem. Also, what other plugins do you have activated? I really want to track this down for you.

  11. craigbic
    Member
    Posted 3 years ago #

    Allow New Registrations to set their own Password is checked. First Name, Last Name, Website, AIM, Yahoo IM, Jabber / Google Talk, About Yourself are ALL checked with First Name and Last Name checked for "required". Enable License Agreement is checked. Enable Privacy Policy is checked and that's it. I have a lot of plugins installed in addition to Register-Plus-Redux so I would not be surprised if it's a plugin conflict. I realize the list is super long and don't expect you to track this down if nobody else is reporting the problem. For now, I just use FTP to rename the Register-Plus-Redux plugin folder to gain access to the plugins page and then rename it back and reactivate when I'm done on the plugins page. I appreciate all the effort you have put into the plugin! Thank you!

    -----installed plugins, trackhacker.com-------
    - Advertising Manager (v. 3.4.19) by Scott Switzer.
    - AJAX Comment Preview (v. 2.3) by Michael D Adams.
    - Akismet (v. 2.4.0) by Automattic.
    - AmazonPress (v. 9.0.1) by Tom Makela (Added: DEFRCAJP) Original author — Warkior.
    - And The Winner Is… (v. 1.0.1) by Spencer Sokol.
    - Block Bad Queries (BBQ) (v. 1.0) by Perishable Press.
    - Broken Link Checker (v. 0.9.6) by Janis Elsts.
    - BulletProof Security (v. .45.3) by Edward Alexander.
    - cbnet Ping Optimizer (v. 2.3.3) by Chip Bennett.
    - Contact Form 7 (v. 2.4.1) by Takayuki Miyoshi.
    - Custom Smilies (v. 2.9.1) by Crazy Loong.
    - DBC Backup (v. 1.1) by Chris T..
    - Duplicate Post (v. 1.1.1) by Enrico Battocchi.
    - Enable Media Replace (v. 2.3) by .
    - Evermore (v. 2.3) by Bennett McElwee.
    - fortunate (v. 1.4.4) by Mike Macgirvin.
    - Google XML Sitemaps (v. 3.2.4) by Arne Brachhold.
    - Greg’s High Performance SEO (v. 1.4.3) by Greg Mulhauser.
    - grf-Dilbert (v. 1.0.2) by GrefTek.
    - Hover (v. 0.6.13) by Stefan Völkel.
    - Login LockDown (v. v1.5) by Michael VanDeMar.
    - NextGEN Gallery (v. 1.6.2) by Alex Rabe.
    - Plugins list (v. 1.0) by Davide Benini.
    - Print Friendly & PDF (v. 1.4) by PrintFriendly.
    - Quote Comments (v. 2.1.2) by Joen Asmussen.
    - Really Simple CAPTCHA (v. 1.2) by Takayuki Miyoshi.
    - Recently Updated Posts (v. 0.4) by Hannes Hofmann.
    - Redirection (v. 2.1.29) by John Godley.
    - Reflect (v. 0.1.3) by Travis Kriplean.
    - Regenerate Thumbnails (v. 2.0.3) by Viper007Bond.
    - Register IP (v. 0.3.2) by Johnny White.
    - Secure WordPress (v. 1.0.2) by jremillard.
    - SexyBookmarks (v. 3.2.4.2) by Shareaholic.
    - Shiba Gravatar (v. 1.2) by ShibaShake.
    - SI CAPTCHA Anti-Spam (v. 2.6.2) by Mike Challis.
    - Special Text Boxes (v. 3.7.51) by minimus.
    - SwfObj (v. 0.9.2) by Matt Carpenter.
    - Theme Test Drive (v. 2.7.5) by Vladimir Prelovac.
    - TinyMCE Advanced (v. 3.2.7) by Andrew Ozz.
    - Tiny Style (v. 0.0.1) by Windy Road.
    - TransDeluxe (v. 1.3.3) by TransDeluxe Team.
    - Twitter Friendly Links (v. 0.5) by Konstantin Kovshenin.
    - Twitter Widget Pro (v. 2.2.0) by Aaron D. Campbell.
    - Ultimate Google Analytics (v. 1.6.0) by Wilfred van der Deijl.
    - Updated Today Banner (v. 2.2.1) by Chris Klosowski.
    - WordPress.com Stats (v. 1.7.3) by Andy Skelton.
    - WordPress Video Plugin (v. 0.744) by Oliver Wunder.
    - WP-Auto Trackback Sender (v. 1.2.6) by Dan Fratean.
    - WP-Cleanup (v. 1.1.0) by JortK.
    - WP-TagTip (v. 0.1) by Eduardo Daniel Sada.
    - wp-Typography (v. 2.0.2) by Jeffrey D. King.
    - WP-UserOnline (v. 2.80) by Lester GaMerZ Chan & scribu.
    - WP Maintenance Mode (v. 1.6.5) by Frank Bültge.
    - Zemanta (v. 0.6.6) by Zemanta Ltd.
  12. radiok
    Member
    Plugin Author

    Posted 3 years ago #

    saury316, I made huge changes today with version 3.6.9 including re-writing the password strength meter, let me know how that works for you now.

  13. craigbic
    Member
    Posted 3 years ago #

    So far so good! I can see my plugins page now and the password strength meter appears to be working too! Everything seems to be working great! Thank you!

  14. radiok
    Member
    Plugin Author

    Posted 3 years ago #

    craigbic, register_activation_hook seems to be the culprit, but why... I'm not sure! I was using it for the wrong thing anyway, but I'm not keen on the init method I'm using either... I'll have to dig around some more. Regardless I'm glad everything's working for you. One last thing, I didn't even test it, does let the user set their own password even work, I mean I'm a super awesome programmer and all so I couldn't have possibly made a mistake? Yeah right, anyway, I'll give it a shot later and make sure!

  15. radiok
    Member
    Plugin Author

    Posted 3 years ago #

    OK, checked it out, user set passwords work.

  16. saury316
    Member
    Posted 3 years ago #

    hey radiok, just updated to 3.6.9, and it seems that stylistically some things broke.

    The custom fields I've added now look like normal textboxes instead of being styled like the username and password boxes that wordpress generates.

    Also, another stylistic issue I saw previously but forgot to mention: Is there any way to add breaks in a radio field? right now it looks like a string of text with buttons, and looks messy. I added it before by hardcoding it into your php code, but would prefer not to do that (as it breaks every time there is an update :P)

  17. saury316
    Member
    Posted 3 years ago #

    Found a bigger issue:

    The text fields for First name and Last name (as selected on the options page from the Checkbox) are no longer showing up.

  18. saury316
    Member
    Posted 3 years ago #

    Also, at the bottom of the registration page, after the Password Strength meter, it says the following:
    Your password must be at least seven characters long. To make your password stronger, use upper and lower case letters, numbers, and the following symbols !@#$%^&*()
    A password will be e-mailed to you.

    Shouldn't it not say "A password will be e-mailed to you" as they are setting their own?

  19. saury316
    Member
    Posted 3 years ago #

    ok..i was being an idiot...redact the issue about First Name and Last Name not showing up.

  20. radiok
    Member
    Plugin Author

    Posted 3 years ago #

    saury316, I changed all the CSS in 3.6.10, so it should look a lot nicer out of the box. Also, I added breaks, I actually never used checks or radios so I hadn't realized how ugly they were! Annnd, I hid the password message, thanks for your feedback!

  21. saury316
    Member
    Posted 3 years ago #

    just updated to 3.6.10 and it really doesn't look all that better. am i doing something wrong?
    http://yfrog.com/cbscreenshotjop

  22. radiok
    Member
    Plugin Author

    Posted 3 years ago #

    Hm, odd, could you post the CSS from the header? And the HTML specifically from where those fields are?

  23. saury316
    Member
    Posted 3 years ago #

    http://www.alliedasia.com/wp-login.php?action=register

    That's the registration page. Feel free to go through the code:

    [Large code excerpt removed by moderator. Per forum rules, please use the pastebin for all large code excerpts. It works better anyway.]

  24. craigbic
    Member
    Posted 3 years ago #

    I updated to 3.6.11 and now my plugins list is blank again and I have to rename register-plus-redux folder to something else so WP will deactivate plugin so I can see the list. Doh!

  25. radiok
    Member
    Plugin Author

    Posted 3 years ago #

    What version were you running prior to updating to 3.6.11?

  26. craigbic
    Member
    Posted 3 years ago #

    3.6.10

  27. radiok
    Member
    Plugin Author

    Posted 3 years ago #

    saury316, I fixed your bug and I also have a suggestion. You have a radio field "We are a :-", with the following options "Retailer , Wholesaler , Distributor , Manufacturer , Other". That would look a lot better if you changed the name of the field to "We are a:" and changed the values to "Retailer,Wholesaler,Distributor,Manufacturer,Other". If you've had that field for awhile, that would require some backend cleanup in the usermeta table, but it looks a lot nicer, IMO.
    http://tinypic.com/r/sgu5vb/7

  28. radiok
    Member
    Plugin Author

    Posted 3 years ago #

    craigbic, with version 3.6.13 are you still having the same plugins page issue?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic