WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Register Plus] Bug?? %invitecode% not being sent in Custom Admin Email (5 posts)

  1. rogerr
    Member
    Posted 5 years ago #

    Fantastic plugin...needs updating but still works...sorta

    Can anyone shed some light on why the plugin is not picking up the Invitation Code and sending it in the custom Admin Email...

    I have tried using %invitecode%, %invite_code%, checked the .php file and for the life of me cannot see why it doesn't send it.

    I have a number of clients (photography) each with a different invite code and use the invite codes to track friends & family registrations.

    I can go in through myPHP and have a look at the database (it is stored there against the new user as invite_code), but this is pretty time consuming if I have 20-30 registrations in a day!!!

    I see two possible solutions: 1. Somehow hack the code to send the email with the invite code to the admin or 2. Add a hook to include the invite code on the verify users page...

    Any ideas???

  2. liviuf
    Member
    Posted 4 years ago #

    I have the same problem. I also looked around on other topics and could not find a solution yet. Any idea would be greatly appreciated. Great plugin btw but it still requires some fine-tuning, shame it is not developed anymore...

  3. svedman
    Member
    Posted 4 years ago #

    You need to change lines 1844 and 1908 in register-plus.php to:

    if( $regplus['code'] ) $message = str_replace('%invitecode%', $_POST['regcode'], $message);

  4. miguelnetto
    Member
    Posted 4 years ago #

    I m confused in the change said by svedman

    In register-plus.php (last version downloaded in WP repository) in the line 1844 have the code:
    if( $regplus['adminhtml'] && $regplus['admin_nl2br'] )

    In line 1844 is the correct code to change?

    In the line 1908 just have else, complement of the code in line 1907:

    $siteurl = get_option('siteurl') . "/wp-login.php" . $email_code . '&' . $redirect;
    		else
  5. Seth Carstens
    Member
    Posted 4 years ago #

    I didn't find on his lines at all
    do a "FIND AND REPLACE for all code that says
    $_POST['code']

    and replace it with
    $_POST['regcode']

Topic Closed

This topic has been closed to new replies.

About this Topic