WordPress.org

Ready to get started?Download WordPress

Forums

Reed Write
[resolved] Incompatible with SEO plugin (9 posts)

  1. shmk
    Member
    Posted 2 years ago #

    If I activate Reed Write 1.4.0 and WordPress SEO 1.0.3 (the one by Yoast), the sitemap_index.xml generated by the SEO plugin become a 404.

    I have a others plugins, but just this is having this kind of problem.

    http://wordpress.org/extend/plugins/reed-write/

  2. Sebastian Cork
    Member
    Posted 2 years ago #

    I can confirm that this problem exists, as I was able to reproduce it based on the above post.

  3. bridgetwes
    Member
    Posted 2 years ago #

    I can confirm this problem exists also.

  4. inspiredmind
    Member
    Posted 2 years ago #

    Three people have taken the time to identify this issue is happening, and I am wondering if anything is being done about it, or has been done about it? It's been two months since it was first pointed out, and the most recent case was 15 hours ago... so I assume the issue is still there?

    Thank you...
    Jonathan (another Yoast SEO user)

  5. Joost de Valk
    Member
    Posted 2 years ago #

    Does anyone have a site with both active where i could see the erroneous output?

  6. Joost de Valk
    Member
    Posted 2 years ago #

    Found the issue, reed-write does a flush_rewrite_rules() on each page load, which is both a very heavy call and makes it impossible for plugins like mine to work in a proper way, to the author of reed-write will have to fix that.

  7. inspiredmind
    Member
    Posted 2 years ago #

    Thanks Joost. I appreciate you taking a look into this. Such service!!

    Well.... It sounds to me like Read Write won't be reading and writing on my site then. "Pass".

    Hopefully the author resolves it, even if just to improve the efficiency of his/her on plug-in.

    Cheers,

    Jonathan

  8. Joost de Valk
    Member
    Posted 2 years ago #

    So do I :)

  9. iambriansreed
    Member
    Plugin Author

    Posted 2 years ago #

    Apologies folks. I removed the flush_rewrite_rules() issue in 1.5.0.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic