WordPress.org

Ready to get started?Download WordPress

Forums

Redirection
My homepage is being redirected to a page - need some help! (19 posts)

  1. rewiremedia
    Member
    Posted 3 years ago #

    Hi. I created a new page on my blog and then I saved it. Then I decided to check my website and it would not go to my homepage anylonger...rather it would only go that page I created....so I deleted and page I created and it still will NOT go to my homepage...I had to disable the redirection plugin to make it work again but I really need to use this for 301 redirects

  2. areyouheartbreaker
    Member
    Posted 3 years ago #

  3. rewiremedia
    Member
    Posted 3 years ago #

    Thanks I will check that out now!

  4. archondigital
    Member
    Posted 3 years ago #

    I get the same error on the redirection plugin since updating

  5. archondigital
    Member
    Posted 3 years ago #

    It now works after following the fix on that link, thanks

  6. maorb
    Member
    Posted 3 years ago #

    I spent 5 hours with this bug, I thought something was wrong with my custom content type I added or something else.
    Only now I managed to find that this redirection plugin was responsible for this mess.
    I'm going to try the fix now and see if it helps.

    Thanks

  7. Nairolf
    Member
    Posted 3 years ago #

    I had exactly the same problem with our web site ACORAM.com and now I'm happy to see that I'm not the only one ;) I will fix this, thank you

  8. pickled
    Member
    Posted 3 years ago #

    my wordpress home page was redirecting too all of the sudden...drove me batty until I found this fix for the wordpress homepage redirection problem.

    similar to above, but better since I need my redirections active for seo. I'd love to know why this is happening to us all all of the sudden?

  9. Milos Spasic
    Member
    Posted 3 years ago #

    Solution form link above works like a charm, thanks! ;-)

  10. rolandosw30
    Member
    Posted 3 years ago #

    Thanks people! This has solved my two day long struggle

  11. ladykathleen
    Member
    Posted 3 years ago #

    This option is great if you don't want that section of the plugin to work, but for those of you that want it to work and it keeps redirecting your front page I have found a solution for you. are your a heartbreaker almost had it but with that one every time you make a new post you have to do in and delete the redirect it made again and again.

    here is the better solution:
    under the module wordpress
    use Add new redirection
    in the source url enter your home page.
    under ACTION select "DO NOTHING"
    you may later see others added but with this one in there it seems to ingore the others. so you can delete the others anytime without your front page being redirected.

    I have only tested this a couple times but it seems to work on my blog. I hope this helps any one looking for a working solution.

  12. FolioVision
    Member
    Posted 3 years ago #

    This can be solved by turning off URL Monitoring. We create our redirections by hand anyway, so we don't mind that.

    I believe that this problem appears, when you write a new post and you save it as a draft before writing any title. So Redirection plugin remembers empty post/page slug for it. Then, when you add the title and you save the post, Redirection detects that as a change and creates redirection:

    / (no page slug)
    ->
    /about-page (new page slug for About page)

    Thanks,
    Martin

  13. migueleste
    Member
    Posted 3 years ago #

    Hi,

    You are absolutely right and I can see a lot of people struggling with this.

    It happened the same to me and it took me ours to figure out what was going on.

    I turned that option off.

    Before this last situation with the homepage I had already detected some "strange" behavior with links I had changed..this was it.

    And if the author is reading this I would strongly advise that this option comes OFF by default.

    I do understand that it is great to have this automatic when you decide to change one post link...but it can't be active by default, more or less hidden in the plugin pages.

    my 2 cents.

    miguel

  14. mordaga
    Member
    Posted 3 years ago #

    areyouheartbreaker's link seems to have fixed the issue for me.

    However, this is really just a work around. It would be great if the author could look into this new bug.

  15. John Godley
    Member
    Plugin Author

    Posted 3 years ago #

    I have as yet been unable to reproduce a problem with auto-redirecting URLs. If anyone can recreate this then please do get in contact with me with the steps you performed. If you have a site where this is happening and I can see it in action then all the better.

  16. FolioVision
    Member
    Posted 3 years ago #

    Hello John,

    I'm sending this both to WordPress.org forums and your contact form:

    This is how you replicate the problem with automatic redirection on homepage:

    1. install Redirection and activate it.
    2. start writing a new page and save it as a draft before adding a title.
    3. now add some title and publish it.
    4. open your WordPress homepage and watch it redirect
    5. open Tools -> Redirection -> Groups -> Modified Posts (1) and you will see the faulty redirection rule

    Thanks,
    Martin

  17. John Godley
    Member
    Plugin Author

    Posted 3 years ago #

    I cannot reproduce this using a fresh installation of WP 3.1.1. There must be some other setup involved - a plugin, some WP configuration?

  18. FolioVision
    Member
    Posted 3 years ago #

    Hi John,

    I did it again on a totally fresh WP 3.1.1.

    Here are the extra steps before above:

    1. Fresh install of WP
    2. Settings -> Permalinks -> Set to /year/month/post-name/
    3. Install Redirection with integrated installer from web

    Then goes the rest.

    Thanks,
    Martin

  19. John Godley
    Member
    Plugin Author

    Posted 3 years ago #

    Martin / Alec,

    Sorry, that's not happening for me! Exactly following your steps and the page is added with no redirections being created.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic