WordPress.org

Ready to get started?Download WordPress

Forums

Really Static
Can i instruct RS to sync plugin and theme content? (7 posts)

  1. joost.bijl
    Member
    Posted 3 years ago #

    I really love the philosophy behind RS due to security concerns. My goal is to maintain a website on private systems and 'publish' updates to public systems using a mechanism such as RS.

    While testing it i found that it doesn't copy content from my themes and plugins. This would however be desired. If i manually copy all non-php files from the plugins and themes directory to the static server it works perfectly.

    The reason that it doesn't pull this in is probably that the referenced files are embedded in CSS and Javascript (ie backgrounds and images for use in javascript-sliders).

    I'm using wordpress 3.2.1, the Genesis framework from StudioPress with Associate child theme and the Genesis slider (among other plugins).

    Of course i can rsync these two directories but it would be more elegant if RS does this.

    Is this an installation issue or is this a feature yet to be programmed?

    http://wordpress.org/extend/plugins/really-static/

  2. joost.bijl
    Member
    Posted 3 years ago #

    Perhaps it's ugly, but i got it working. Perhaps this is something for inclusion in the next release?

    [Code moderated as per the Forum Rules. Please use the pastebin]

  3. illuminea
    Member
    Posted 3 years ago #

    Joost, how did you get it to sync your plugin and theme content?

  4. joost.bijl
    Member
    Posted 3 years ago #

  5. illuminea
    Member
    Posted 3 years ago #

    Thanks Joost!

  6. FrankWhite
    Member
    Posted 2 years ago #

    I can't seem to get your modification to work, Joost. I'm sure it's something simple, like the path, perhaps.

    Here's the last part of the configupdate.php code:
    http://pastebin.com/mfP9pxLh

    Thanks for your help. By the way, this plugin is great; with a few tweaks, it could be amazing!

  7. joost.bijl
    Member
    Posted 2 years ago #

    Hi Frank,

    the first argument to getnpush() should be the absolute path on your server running wordpress. On the pastbin code it shows a URL instead of a path.

    Please let me know if this fixes it!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic