WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Plugin readme.txt & stable tags (5 posts)

  1. Jesse LaReaux
    Member
    Posted 2 years ago #

    Thanks in advance for your help. I've just written my first plugin and submitted it to the plugin repo. I had to do a quick bug fix and so I made a new stable tag and updated the readme.txt, updated the trunk files and also added it to the tags folder. The problem is that the current version is 0.2 and the plugin page still says 0.1, I had to delete 0.1 from the tags folder in the repo so that it wasn't the version people were downloading.

    Please help me figure this out. the plugin is 'CommunityPress' heres a link to the plugin page and repository.

    http://wordpress.org/extend/plugins/communitypress/
    http://plugins.svn.wordpress.org/communitypress/

  2. Joshua Parker
    Member
    Posted 2 years ago #

    In the cp_loader.php file, it still states version 0.1. You might want to update that and then commit it. Now, since you deleted version 0.1, you might run into some issues. If so, let me know and we will try to troubleshoot it.

    BTW, nice plugin. I look forward to testing it out.

  3. Jesse LaReaux
    Member
    Posted 2 years ago #

    thanks again, that did the trick! I've got an issue with screenshots not showing on the plugin page. Any ideas on that one?

  4. Joshua Parker
    Member
    Posted 2 years ago #

    Yes, your screenshots should match what you have in your readme.txt file. So for instance you have

    1. **Home Page** - The site Home page.

    So instead of "home page.PNG", it should be named screenshot-1.png and so forth.

  5. Jesse LaReaux
    Member
    Posted 2 years ago #

    Got it :)

Topic Closed

This topic has been closed to new replies.

About this Topic