WordPress.org

Ready to get started?Download WordPress

Forums

Raw HTML
Not working in WP 3.01, or user error? (6 posts)

  1. BrianD
    Member
    Posted 3 years ago #

    I'm trying to overcome the nasty habit WP has of trying to correct my code for me. I'm using a clean test site with v3.01 and I don't think there are any conflicting plugins (using TinyMCE). I'm attempting to format a page using only the HTML editor... I installed the plugin and see this:

    <!--start_raw-->
    <div class="headerblock"><span class="headertitle">some text here</span><br />
    <hr />
    </div>
    <!--end_raw-->

    turn into this after save:

    <p><!--start_raw--></p>
    <div class="headerblock"><span class="headertitle">some text here</span></p>
    <hr />
    </div>
    <p><!--end_raw--></p>

    Maddening. I also nuked the wpautop filter in default-filters.php, but no joy. Any suggestions welcome.

    Thanks
    Brian D

    http://wordpress.org/extend/plugins/raw-html/

  2. thempauls
    Member
    Posted 3 years ago #

    Getting same problem here in 3.1

  3. Motoristi
    Member
    Posted 2 years ago #

    Also nothing happening in WP 3.1.1.

  4. inetwerx
    Member
    Posted 2 years ago #

    Similar problem in 3.2

  5. kangenguru
    Member
    Posted 2 years ago #

    This is my snippet of code:

    <script type="text/javascript">
    swfobject.embedSWF("http://www.youtube.com/v/VIDEO_ID?rel=0&enablejsapi=1&playerapiid=myvideo",
      "myvideo", "425", "356", "8", null, null, { allowScriptAccess: "always" });
    </script>

    WordPress inserts #038 after & the snippet becomes like this

    <script type="text/javascript">
    swfobject.embedSWF("http://www.youtube.com/v/VIDEO_ID?rel=0&#038enablejsapi=1&#038playerapiid=myvideo",
      "myvideo", "425", "356", "8", null, null, { allowScriptAccess: "always" });
    </script>

    I am installing this RAW HTML plugin to eliminate HTML/Hex characters from being added by WordPress and RAW HTML blows up the theme (Twenty Ten) altogether.

    Please advise.

  6. kangenguru
    Member
    Posted 2 years ago #

    Sorry, "blows up" doesn't sound very descriptive.

    What I meant by RAW HTML plugin blowing up was my sidebar widgets and the remainder of the content after the code snippet do not show anymore just when the plugin is activated. None of the 4 options selected yet.

    Deactivating the plugin restored the page to the same original problem with WordPress adding #038 after & to get this pesky string &#038.

    Any other ideas to resolve this?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags