WordPress.org

Ready to get started?Download WordPress

Forums

Quotes Collection
Page jumping with ajax refresh (5 posts)

  1. Melissa
    Member
    Posted 2 years ago #

    I am currently using the plugin in my template with the following code:

    <?php quotescollection_quote('random=1&auto_refresh=5&tags=weddings&char_limit=230'); ?>

    The quote is displaying near the top of my page. The problem I am experiencing is that when the quote refreshes automatically, the page jumps way back up to the top. Obviously this creates quite a problem when trying to view content further down the page. Does anyone know of a possible fix for this issue?

    -Thanks

    http://wordpress.org/extend/plugins/quotes-collection/

  2. Pepperfly
    Member
    Posted 2 years ago #

    I've run into this prob. Best way to solve is set {min-height: ###px;}, where ### is the height in pixels of the longest quote (and maybe round up a few extra pixels).

  3. Pepperfly
    Member
    Posted 2 years ago #

    I think I see the problem you are having differently now. I am using the following code:

    <?php quotescollection_quote('ajax_refresh=0&auto_refresh=15&char_limit=250'); ?>

    The char_limit param seems to have no effect. Quotes much longer are being displayed. This is a prob. My previous suggestion to use min-height really only helps if you're not trying to constrain to a shorter space for aesthetic balance. Using the char_limit is the viable option. And adding a class to control min-height and visibility of overflow would also cause aesthetic probs with longer quotes that should not otherwise be displayed if char_limit was working right.

    Another prob I'm having (which I'll start a new thread for) is that the auto_refresh param seems to have no effect. Quotes are still rotating after 5 seconds.

    It's been a month since you posted your original issue and no author response yet? <sigh> I hope the problem can be corrected soon. :-)

  4. Pepperfly
    Member
    Posted 2 years ago #

    I stripped the ajax_refresh param out and the char_limit I set is working now.

  5. lyndonr
    Member
    Posted 1 year ago #

    did anyone figure out how to stop the page from jumping?

    even when I specified a fixed height on the quotes container it still jumps.

    wrote to the developer but have not gotten a reply.

    thanks in advance!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic