WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: QuickPost] WP 2.9.1 : Assigning the return value by reference is deprecated wp-settings.php (6 posts)

  1. rwanito
    Member
    Posted 4 years ago #

    Hi there,

    I 'm trying to install quicl post 0.7 on wp 2.9.1 and I get an error message :

    Deprecated: Assigning the return value of new by reference is deprecated in /opt/lampp/htdocs/wp/wp-settings.php on line 646

    Deprecated: Assigning the return value of new by reference is deprecated in /opt/lampp/htdocs/wp/wp-settings.php on line 661

    Deprecated: Assigning the return value of new by reference is deprecated in /opt/lampp/htdocs/wp/wp-settings.php on line 668

    Deprecated: Assigning the return value of new by reference is deprecated in /opt/lampp/htdocs/wp/wp-settings.php on line 675

    Deprecated: Assigning the return value of new by reference is deprecated in /opt/lampp/htdocs/wp/wp-settings.php on line 711

    Deprecated: Function set_magic_quotes_runtime() is deprecated in /opt/lampp/htdocs/wp/wp-settings.php on line 18

    The plugin configuration works, this error message appear when I open the bookmarklet
    Any idea ?
    Thanks for sharing ..

    http://wordpress.org/extend/plugins/quick-post/

  2. Larro
    Member
    Posted 4 years ago #

  3. Larro
    Member
    Posted 4 years ago #

  4. rwanito
    Member
    Posted 4 years ago #

    Thank you Larro,

    I will have a look and report here

  5. rwanito
    Member
    Posted 4 years ago #

    It works, but :

    I had to replace "=&" by "=" in the lines listed in the error message.
    In my case, I had to modify the core , wp-settings.php , so I'm still searching a better solution, without affecting the core files.

    Note : there is another error message with quick-post and wp 2.9.1 :
    http://wordpress.org/support/topic/356286?replies=1

    I'm still investigating, please help if you can, and stay tuned if you want to use quick post with the recent version of wp. we gonna beat all those bugs !

    See you

  6. danorton
    Member
    Posted 3 years ago #

    This is a WordPress bug* and it persists in 3.0.1.

    See related:
    [Plugin: QuickPost] Deprecated: Function set_magic_quotes_runtime() is deprecated in settings.php

    *I'm presuming that there is some quality standard that prohibits the use of deprecated PHP syntax.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags