WordPress.org

Ready to get started?Download WordPress

Forums

Quick Post Widget
Adding Anti-Spam Captcha Image to QPW? (20 posts)

  1. neodiver
    Member
    Posted 3 years ago #

    Helllo!

    How do we add an anti-spam captcha image to Quick Post Widget?

    We like the widget and are permitting anyone (guests) to post, but we need anti-spam functionality!

    Thanks!

    We are using this widget here, btw.

    http://wordpress.org/extend/plugins/quick-post-widget/

  2. inapan
    Member
    Plugin Author

    Posted 3 years ago #

    @neodive
    The next version 1.7.2 has optional captcha security. It will be ready within one week.
    Perry

  3. keeperbay
    Member
    Posted 3 years ago #

    Will there be an option to limit characters to those posting who aren't logged in. I'd like to limit it to 440 character (like FB)
    This is perfect for our quicky message board, but I want to limit the amount of spam people can leave - eye roll!

  4. neodiver
    Member
    Posted 3 years ago #

    @inapan Any update on the update with captcha included?

  5. inapan
    Member
    Plugin Author

    Posted 3 years ago #

    @neodiver
    Today I uploaded version 1.7.2 with optional captcha.

  6. neodiver
    Member
    Posted 3 years ago #

    Thanks!

    OBTW, we changed the label on the widget that said:

    "Captcha security"

    to

    "Enter image text in box to allow posting"

    Since most people who are not techies have little idea what "captcha security" means :D

    Example here:

    http://www.pattayadivers.com/

  7. duiwel
    Member
    Posted 3 years ago #

    The Captcha does not seem to be working at this time.

    I am not a coder by any means, but I looked through your code, and the code the developer of the Captcha script you used made and things definitely aren't jiving.

    From what I can tell, your code only blocks spammers using form-readers. Using the widget with anonymous posting enable, with captcha, and posts directly to Published seems to be allowing spammers to use URL injection into wordpress hooks or something. I haven't quite figure it out, but the wigdet you made seems to open backdoors for post injection that the Captcha you chose simply isn't blocking.

    Also - when you input a bad code, it generates no error window, it just redirects back to the page.

    I love the widget but I just wish it was more secure.

  8. neodiver
    Member
    Posted 3 years ago #

    We had a problem that after we installed the last update, Google Webmaster tools showed that each page with the QPW occasionally returned an 301 redirect error.

    The problem cleared up after we disabled this widget.

    Our Google SERP ranking took a tremendous hit from the errors; but we are slowly recovering.

    At first we thought it was related to the CAPTCHA code; but even with CAPTCHA disabled, we got a bunch of 301 redirect errors because of this widget.

  9. inapan
    Member
    Plugin Author

    Posted 3 years ago #

    @duiwel
    If you can figure out what the problem is exactly and what seems to be causing it, please let me know.
    BTW, what do you mean by "the code isn't jiving"?

  10. inapan
    Member
    Plugin Author

    Posted 3 years ago #

    @neodiver
    I'm sorry to hear that the widget is causing a problem.
    Did you get the 301's with or without a success message configured?

  11. neodiver
    Member
    Posted 3 years ago #

    With, as I recall.... because we configured for the success message.

    However, when Google indexed the site, it seemed it did not like this line:

    <input type="hidden" id="quick_post_redirect_to" value="/index.php" />

    After days of working to isolate the problem, it turned out to be this widget.

    Sorry for the bad news.

  12. inapan
    Member
    Plugin Author

    Posted 3 years ago #

    @neodiver
    I think your results will be better if you configure the complete URL to redirect to, including http, for instance:

    http://www.pattayadivers.com/index.php

    Could you give it a try?

  13. neodiver
    Member
    Posted 3 years ago #

    Thanks, but we can't afford to have any more Google penalties because of 301 redirect errors when GoogleBot crawls the site.

    We have decided not to use QPW after such a dramatic problem with every page that QPW was showing.

    Our apologies.

  14. inapan
    Member
    Plugin Author

    Posted 3 years ago #

    @neodiver
    I'm sorry to hear you left the QPW. My apologies are for you.
    Tonight I dove into the code and I think I found the solution for what seems to be causing the 301's. The next version should correct this.
    inapan

  15. inapan
    Member
    Plugin Author

    Posted 3 years ago #

    @neodiver
    Today I uploaded version 1.7.3 which has a fix for the 301 errors.
    inapan

  16. johnsimone
    Member
    Posted 3 years ago #

    Just installed. Love it. Works great. CAPTCHA image is a dead link though. ): Any advice on how I might troubleshoot the issue?

    Also, the little pop-up window with the after-post message has a title "Quick Post Widget" -- is there a way to change that?

    Thanks,

    John

  17. inapan
    Member
    Plugin Author

    Posted 3 years ago #

    @johnsimone

    The captcha part depends on the GD & FreeType libraries. You can check them by running phpinfo:

    Put <?php phpinfo(); ?> in a file and check the output mentions GD & FreeType.

    The following page has some troubleshooting tips:

    http://www.white-hat-web-design.co.uk/articles/php-captcha-help.php

    I can try to put options for the popup titles in the next release (which is/was almost ready).

    inapan

  18. Alex
    Member
    Posted 2 years ago #

    On my web-site captcha didn't work also, but after I put the line

    putenv('GDFONTPATH='.realpath('.'));

    in the top of CaptchaSecurityImages.php file in wp-content/plugins/quick-post-widget/utils/captcha problem fixed!

    Thank you for the great plugin!

  19. inapan
    Member
    Plugin Author

    Posted 2 years ago #

    @Alex,

    Thanks for sharing!

    inapan

  20. boogah
    Member
    Posted 2 years ago #

    @Alex: That worked fantastically for a customer issue I was running into over on WP Engine. So thanks for that!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic