WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Quick Chat] There is a comma showing on my users list... (5 posts)

  1. Fernando Yet To Die
    Member
    Posted 2 years ago #

    Hi!

    WOW!

    Quick Chat is AMAZING! Thank you!

    However, my user list shows a comma at the end of each username, how can I remove that?

    Guest1,
    Guest2,
    Guest3,

    I want like this:

    Guest1
    Guest2
    Guest3

    Strange thing is... When there is only ONE person inside my chat, I don't get any commas. It shows like this:

    Guest1

    Please help, thank you!
    See for yourself: http://diablobra.com - click on the demon skull button at your bottom left to open the chat.

  2. Marko-M
    Member
    Posted 2 years ago #

    Hello. Comma should only be shown when user list position is set to "top". Is this your case or for you or comma shows when your user list is set to "left" or "right"?

  3. Fernando Yet To Die
    Member
    Posted 2 years ago #

    Ah! Yeah, it is set to top :D
    And when I put left/right I got no commas!

    Any chance you can point me out to the java line/php line where I can erase the commas?

    I hacked my css to bring the user list to the right side, without knowing these options to do automatically, so when I change from top to right/left, everything breaks.

    :D

  4. Marko-M
    Member
    Posted 2 years ago #

    In PHP see line 1194 from v 2.41 with code:

    if ($userlist_position == 'top' && $u != end($users)){
        $string_all .= ',';
    }

    In JS see line 374 with code:

    if ($userlist_position == 'top' && $u != end($users)){
        $string_all .= ',';
    }

    Good luck!

  5. Fernando Yet To Die
    Member
    Posted 2 years ago #

    You are awesome thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic