WordPress.org

Ready to get started?Download WordPress

Forums

Quick Cache (Speed Without Compromise)
[Plugin: Quick Cache ( Speed Without Compromise )] Quick Cache and CloudFlare (6 posts)

  1. MacArthur
    Member
    Posted 2 years ago #

    Hi,

    I just moved from W3TC to quick cache following a recommendation from an experienced user running multi site installation as I do.
    My site is using cloudFlare.
    Is there any potential interest/conflict?
    Is there anything to configure to maximize effect?
    Thanks in advance for your help
    Cheers,
    Mac

    http://wordpress.org/extend/plugins/quick-cache/

  2. Jaabie
    Member
    Posted 1 year ago #

    I am also running CF, and i am having issues with QC, I cant get it to cache, I wondered if there was any conflict, anyone help with this?

  3. kizora
    Member
    Posted 1 year ago #

    Hi Jaabie,

    What issues are you getting as I'm using Quick Cache and looking at Cloudflare?

    Cheers
    Chris

  4. Jaabie
    Member
    Posted 1 year ago #

    No issues, Its just I cant see to get my cache to work, I started with W3 then tired super cache, now on Quick cache, I i think all the changes has corrupted something.

    Cloudflare was simple to set up, but im not sure its working and not techie enough to trouble shoot. i was hoping for some speed increases however with pingdom.com it is still slower than i wish.

    Jamie - shutterLIVING.com

  5. kizora
    Member
    Posted 1 year ago #

    Hi,

    Problem seems to be that by default Quickcache sends no-cache headers which Cloudflare dutifully obeys.

    It may work properly if you set "Allow Double-Caching In The Client-Side Browser?" in Quickcache to "true"

    Cheers
    Chris

  6. Andrew
    Member
    Posted 1 year ago #

    Hi,

    Did kizora's fix work for anyone else? I'm having what seems like very odd behavior (http://wolfwatcher.org) from CloudFlare and Quick Cache.

    I set "Minimum expire TTL" to 1 month in the CloudFlare settings. I also have Quick Cache installed, with Cache Expiration set to 2592000, which should be 30 days. When Quick Cache is ON, webpagetest.org says the site is NOT caching (http://www.webpagetest.org/result/130811_9H_5CM/), but it loads super fast. When Quick Cache is OFF, webpagetest.org says the site IS caching (http://www.webpagetest.org/result/130811_7P_5BH/), but it loads super slow. Do you have any idea why this is? Is it possible that CloudFlare isn't configured properly still? I tried the Double Caching in Client-Side Browser and that didn't change anything.

    To sum it up:
    Quick Cache OFF = "Cached" but super slow: http://www.webpagetest.org/result/130811_7P_5BH/
    Quick Cache ON = "Un-cached" but super fast: http://www.webpagetest.org/result/130811_9H_5CM/

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.