WordPress.org

Ready to get started?Download WordPress

Forums

Quick Cache (Speed Without Compromise)
[Plugin: Quick Cache ( Speed Without Compromise )] How to verify? Can't see footer comments but (13 posts)

  1. NanoG5
    Member
    Posted 1 year ago #

    Hi,

    I'm using latest version of WP and Quick Cache. But How do I verify the QC is working fine? Because I can't see "This Quick Cache file was built for.." in the footer. I don't minify/strip HTML comments because it's still there (see the screenshot):

    http://f.cl.ly/items/06021i1X0j3k2I38161F/Screen%20Shot%202012-08-10%20at%205.12.10%20PM.png

    However, in the cache directory on my server, there are lots of QC generated file:

    http://f.cl.ly/items/0L0Z2N0m19221p2G3M1Q/Screen%20Shot%202012-08-10%20at%205.15.42%20PM.png

    Any comments or help would be greatly appreciated.
    Thanks!

    http://wordpress.org/extend/plugins/quick-cache/

  2. RonStrilaeff
    Member
    Posted 1 year ago #

    I'm bumping this because I'd like to see that QC verification comment at the end of my view-source file. I do see many current files in the wp-content/cache folder so I guess that's even better proof, but why are the stats/comments not showing up?

  3. constructionlaw
    Member
    Posted 1 year ago #

    I am having the issue using Firefox, but when I open the site in Chrome, the comments show.

  4. Ursula S.
    Member
    Posted 1 year ago #

    I have the same problem, too, in all IE, Firefox and Chrome.

  5. RonStrilaeff
    Member
    Posted 1 year ago #

    By default QC won't cache for logged in users.

    However, even after logging out I sometimes don't see the verification text, but I did after trying 3 different ways to clear my browser cache. Chrome especially tries hard to hang on to everything. Apparently QC uses that to sense you might still be logged in.

    So maybe try Ctrl-F5, and go to the options to clear the cache, then stop and start the browser. I managed to finally see the verification text that way. Good luck!

  6. Ursula S.
    Member
    Posted 1 year ago #

    It works, in all thre browsers. Thank you so much!

  7. IseeDeadPeople
    Member
    Posted 1 year ago #

    Hi,

    I'm having the same problem. I can't see lines in the footer, telling me that Quick Cache is running.

    Yes, I'm logged out. I did try on 4 browsers and Quick Cache doesn't seem to cache any page!

  8. RonStrilaeff
    Member
    Posted 1 year ago #

    You can also verify it is working by looking for recent cached files saved on your server (using filezilla, for example). They start with "qc-" and are in wp-content/cache. Sort them with most recent at the top and look for ones created in the last few minutes.

    Also, if you cleared the qc cache manually (from wp-admin), all those files should disappear. Then navigate with a non-logged in browser to some obscure page, and a new "qc-" file should appear. Open it in an editor (it's plain text) and about 5 lines down you should see the page title. This will be good evidence that it is the page your anonymous visitor requested.

    Minify may also strip out all comments from the page presented to the user, but the raw cached file might still have the qc comments at the bottom. I'm not perfectly clear on that last statement, but I think minify's purpose in life is to strip out all non-executable code to reduce load time.

  9. IseeDeadPeople
    Member
    Posted 1 year ago #

    Thanks for your answer. It makes everything more clear :)
    But, it doesn't help my Quick Cache plugin to work...

    I did everything like you said, and my wp-content/cache directory is always empty! The perms set on this directory are : 755, I hope it's all ok...

    Is there any log somewhere so I could see if there's any error message with Quick Cache?

  10. RonStrilaeff
    Member
    Posted 1 year ago #

    Mine is 755 too so that's not the problem.

    Dumb question: on the bottom of the wp-admin sidebar, open up Quick Cache -> Config Options, and make sure that quick cache is enabled (after being activated). I know that's one of those "Is it plugged in?" questions but it should work with an auto install and default settings.

    I don't see any error log file mentioned in the documentation but php (or wp, not sure) generates an "error_log" file in the wp-admin folder (and maybe other places).

    You can also put this in your wp-config.php file and then change the first false to true temporarily. It will create a debug.log log file inside the /wp-content/ directory.

    define( 'WP_DEBUG', false );  // false or true
    if (WP_DEBUG) {
      define('WP_DEBUG_LOG', true);
      define('WP_DEBUG_DISPLAY', false);
      @ini_set('display_errors',0);
    }

    But before you do all that, just make sure the qc is actually turned on :-P

  11. IseeDeadPeople
    Member
    Posted 1 year ago #

    Woah thanks for the error_log, I didn't know about this one! I had a 34MB file, which I downloaded to see its content, but no trace of Quick Cache in there. It was useful anyway, because with this error_log I noticed that my wp_slimstat plugin (web analytics) was throwing LOTS of errors. I decided to uninstall this plugin and install Piwik instead.

    I emptied error_log, to start with a brand new file. I've put the WP_DEBUG stuff at the end of my wp-config.php file.

    The wp-content/cache directory is still empty, and my error_log file doesn't show any new content.

    I gotta tell you, Quick Cache was working on this website last week. At one point I needed to delete all posts on my website and start again from scratch. At this time I decided to delete all files in the cache directory manually. Since that time, there's no way for me to get Quick Cache running again! I tried to uninstall/reinstall the plugin, turn it off and turn it on again (via the Quick Cache Config Options), but none of these are working.

    :(

    Thanks for helping!

  12. Kimberly
    Member
    Posted 1 year ago #

    RE: why qc isnt working right now for ya....Could be a conflict with another plugin. Try disabling all your plugins and then enable quick cache.

    Also do you see a "advanced-cache.php" file in you /wp-content directory?

    Btw, even if u enabled DEBUG that doesnt mean you will see information about a plugin since it is dependent on a plugin actually writing out debug information which most plugins don't unfortunately.

  13. IseeDeadPeople
    Member
    Posted 1 year ago #

    Thanks everyone for your help, and Kellog9 for your last message. You saved my life!

    The trick was to disable the latest installed plugins one-by-one. I found one conflicting plugin and Quick Cache got back to work :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic