WordPress.org

Ready to get started?Download WordPress

Forums

Quick Cache (Speed Without Compromise)
[Plugin: Quick Cache ( Speed Without Compromise )] File permissions "error" (4 posts)

  1. Knut Sparhell
    Member
    Posted 1 year ago #

    Error: Could NOT enable Quick Cache. Please check permissions on /wp-config.php, /wp-content/ and /wp-content/cache/. Permissions need to be 755 or higher.

    This message is not true. The wp-content and cache folders already have 755.

    The caching works, so it is enabled.

    Why does this plugin reguire access to the wp-config.php? It is in the parent folder of the site. I'm not even allowed to change it's permissions, but I'm allowed to change it. No plugin will ever gain access to change it on it's own.

    So just get rid of these meaningless "error" messages. It works as it should, and that's all I want to hear.

    http://wordpress.org/extend/plugins/quick-cache/

  2. vrossign
    Member
    Posted 1 year ago #

    Hi! Very nice plugin!

    I'm wondering why the plugin requires to write to wp-content? Isn't advanced-cache.php the only file it will write in this directory? Setting wp-content writable is almost impossible on many shared hosting. It may be possible to do it for a single file though.
    => That's why I would recommend to check if file wp-content/advanced-cache.php is writable and if not display the error and prevent the activation.

    Also, wp-config.php edit isn't really necessary as long as define('WP_CACHE', true) is in, right ?
    => I would recommend to first check if this param is in the file, if not and the file is not writable then display the error and prevent the activation.

  3. frostedlemon
    Member
    Posted 1 year ago #

    I have the exact same issue - the only way I can remove the errors is to set wp-config.php to 777.

    The recomended 755 produces the following errors -

    Error: Could NOT enable Quick Cache. Please check permissions on /wp-config.php, /wp-content/ and /wp-content/cache/. Permissions need to be 755 or higher.

    Permissions: Please check permissions on /wp-config.php. Quick Cache needs write-access to this file. Permissions need to be 755 or higher.

    It IS set to 755...

  4. Sopratutto
    Member
    Posted 1 year ago #

    Same issue here. Gives me error message when set to 755. Whats up with that?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.