WordPress.org

Ready to get started?Download WordPress

Forums

Question and Answer Forum
[resolved] Missing argument 2 for q_answeremail_message - Please Suggest (3 posts)

  1. tankard
    Member
    Posted 3 years ago #

    Hi, great plugin, I like it. One problem though. When I'm trying to post an answer, this happens:

    Warning: Missing argument 2 for q_answeremail_message() in /home/children/public_html/motorquestions.com/wp-content/plugins/question-and-answer-forum/answeremail.php on line 4
    
    Warning: Missing argument 2 for q_answeremail_subject() in /home/children/public_html/motorquestions.com/wp-content/plugins/question-and-answer-forum/answeremail.php on line 18
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/children/public_html/motorquestions.com/wp-content/plugins/question-and-answer-forum/answeremail.php:4) in /home/children/public_html/motorquestions.com/wp-includes/pluggable.php on line 897

    The answer actually gets posted, so the plugin IS working. Can you please suggest how do I add that mysterious argument 2? Thanks!

    http://wordpress.org/extend/plugins/question-and-answer-forum/

  2. trevorpythag
    Member
    Plugin Author

    Posted 3 years ago #

    Hi thanks for trying out the plugin.

    Which version of the plugin and wordpress are you using?

    Seems strange that this argument is missing. You could try specifying the number of arguments in the filter hook by changing lines 2 and 3 of answermail.php to
    add_filter('comment_notification_text','q_answeremail_message',10,2);
    add_filter('comment_notification_subject','q_answeremail_subject',10,2);

    I will look into possible causes of this error,
    Dave

  3. tankard
    Member
    Posted 3 years ago #

    Whoohoo! Thank you very much. That fixed it!

    I was using the very latest version of WP and Q&A - I just downloaded them both.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic