WordPress.org

Ready to get started?Download WordPress

Forums

Query Posts
[resolved] Show specific ID doesn't work (8 posts)

  1. Michelle Langston
    Theme Wrangler at Automattic
    Posted 3 years ago #

    I was so excited to find this plugin, but it appears to be broken under WordPress 3.0.1. If you put in a specific page or post ID, it does not display that particular page or post. :(

    http://wordpress.org/extend/plugins/query-posts/

  2. Ivaylo Draganov
    Member
    Posted 3 years ago #

    I confirm having the same issue...

    It respects the post_type, order and orderby parameters but not the ID - it just shows the fisrt post according to other parameters.

  3. Michelle Langston
    Theme Wrangler at Automattic
    Posted 3 years ago #

    OK I'm glad to know I'm not the only one having this issue. I guess we will have to wait for Justin to release a fix.

  4. jeobrussels
    Member
    Posted 3 years ago #

    I can confirm this behaviour: neither Category ID nor a comma-separated list of post-IDs is taken up.
    All other parameters work.

  5. Michelle Langston
    Theme Wrangler at Automattic
    Posted 3 years ago #

    It's definitely a bug. Hopefully Justin fixes it in the next version! :)

  6. Ivaylo Draganov
    Member
    Posted 3 years ago #

    Custom taxonomies also don't get picked up. I mean - they appear as input fields but entering an ID doesn't make it print posts from the specific taxonomy.

    In fact anything other than category is not working. Anybody know a way how to at least debug this thing?

  7. canofpopcom
    Member
    Posted 3 years ago #

    I can't get Category to work either.. just shows all posts. :( Tags and pages seem to work but really wanted to use Categories rather than tags.

    Ummz

  8. newportcreativegroup
    Member
    Posted 3 years ago #

    Same problem, here's the fix. It's missing the argument for a single post in the widget-query-posts.php file. Open that up and add in the following at line 123, right before you see:
    /* Begin display of widget

    /*NCG edit */
    if( $instance['post'])
    $args['p'] = $instance['post'];

    Problem solved. Thanks for Justin for a ridiculously useful plugin. Just discovered it a couple of weeks ago and it makes me want to cry how many custom bits of code I set up on templates that I could have accomplished with widgets using this plugin. It's flat out amazing!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic