WordPress.org

Ready to get started?Download WordPress

Forums

Query Multiple Taxonomies
Checkbox view does not filter the right posts (14 posts)

  1. Thompson1985
    Member
    Posted 1 year ago #

    When using the checkbox view of this plugin it does not filter the right postst i guess. When using the lists view it does perfectly what i want but when using the checkbox view and selecting 1 tag it just show all te posts on my website like no filter is working...

    http://travelinhappiness.com

    http://wordpress.org/extend/plugins/query-multiple-taxonomies/

  2. Thompson1985
    Member
    Posted 1 year ago #

    Hi Scribu,

    Did you encounter this problem as well? think something is wrong with the checkboxes code. It does not filter any taxonomy's. "Lists" view is working like it should.

  3. scribu
    Member
    Plugin Author

    Posted 1 year ago #

    It works as expected on my test site.

  4. Thompson1985
    Member
    Posted 1 year ago #

    when you go to http://travelinhappiness.com/ on the homepage i use the checkboxes view. Try to check only 'bars' and then submit. It will still show all posts.

    when you go to: http://travelinhappiness.com/category/europe/greatbritain/london/ i used the lists view there. When you click 'bars' (or another option) there, it works like it should..

    any idea? It's not the differnce between category page and homepage... i also tried the lists view on the homepage and that works fine

  5. Thompson1985
    Member
    Posted 1 year ago #

    do i need another plugin to make the taxonomy's or something? right now i'm filtering on Tags. So maybe that's the problem

  6. Thompson1985
    Member
    Posted 1 year ago #

    it gives this url when submiting a checked 'tag'

    http://travelinhappiness.com/?qmt%5Bpost_tag%5D%5B%5D=55

  7. AzzePis
    Member
    Posted 1 year ago #

    the same issue i have. with the listing mode i got url like this:
    http://domain.com/?colors=red&columns=left-sidebar-2&subject=personal-blog&width=fixed-width
    but with the ckeckboxes mode and the same filter options i've got:
    http://domain.com/?qmt%5Bwidth%5D%5B%5D=277&qmt%5Bsubject%5D%5B%5D=359&qmt%5Bcolumns%5D%5B%5D=275&qmt%5Bcolors%5D%5B%5D=264

    and in the first way i had the posts which much filter criteria, and in the second - not understendble for me set of posts from all categories

  8. Thompson1985
    Member
    Posted 1 year ago #

    So i'm not the only one with this problem. Any chance to replicate the error Scribu?

    [ Please do not bump, that's not permitted here. ]

  9. johnson.sg
    Member
    Posted 1 year ago #

    Yeah, this does not work at all with the checkboxes. What is the test site it is working on so I can check it out. This seems to be a problem with everyone when using checkboxes

  10. johnson.sg
    Member
    Posted 1 year ago #

    Yeah, this does not work at all with the checkboxes. What is the test site it is working on so I can check it out. This seems to be a problem with everyone when using checkboxes

  11. mattedw
    Member
    Posted 1 year ago #

    I can recreate this issue as you describe it. WP 3.5

  12. slaaxy
    Member
    Posted 1 year ago #

    Same problem in WP 3.5

    It is listing posts it shouldn't.

  13. pey22
    Member
    Posted 1 year ago #

    Hello
    I have this problem as well.
    Someone was able to fix it?

  14. aspratley
    Member
    Posted 1 year ago #

    If you're trying to filter custom post types you may run into an issue. You'll need to include the custom post type in your query somehow. Perhaps with this:

    http://codex.wordpress.org/Post_Types#Custom_Post_Types_in_the_main_Query

    I only need to filter one type of post type so I've added:

    $request['post_type']='the_custom_post_type/s';

    to QMT_Hooks->request (core.php)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.