WordPress.org

Ready to get started?Download WordPress

Forums

Qtranslate Slug
Logo Link Problem (3 posts)

  1. mariorj
    Member
    Posted 1 year ago #

    Carlos, first... thanks for your plugin

    I'm having problems with the Logo/home link. Qtranslate-slug plugin is adding an extra /es/ in the href.

    Should be http://www.maro.cr/es/ and is making a http://www.maro.cr/es/es

    How can I solve this?

    http://wordpress.org/extend/plugins/qtranslate-slug/

  2. Carlos
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    what function are you using for this permalink?

  3. mustbuzz
    Member
    Posted 11 months ago #

    I am using the qTranslate plugin and I modify it myself like this

    First, try to add this code

    add_filter('home_url', 'qtrans_convertURL');

    in the qtranslate_hooks.php at add_filter area.

    Don’t forget to always adding this code whenever you update the plugin, because the update will replace the old file.

    OR mywordpress/themes/template/function.php or framework.php

    and set your logo link like this
    Second option if above doesn’t work.

    Copy the home WordPress file and make it a new template as frontpage.

    Open the home.php in dreamweaver, save as another file and don’t forget to add this code to make it as a new template for frontpage.

    Add this code before <?php get_header(); ?>

    /**
    * Frontpage Template
    *
    Template Name: Frontpage Page
    */

    Just leave the rest code as it is and upload this file in your WordPress directory.

    Create a new page, name it home, select Frontpage template in the Page Attributes.
    Go to Settings > Reading > and select home as your frontpage.
    Now you have a translated front page.
    - See more at: http://mustbuzz.net/web-design/how-to-create-multiple-language-website-in-wordpress/#sthash.esoFSSrJ.dpuf

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.