WordPress.org

Ready to get started?Download WordPress

Forums

qTranslate
[resolved] Editor issue: Second language area clone text from the first language (16 posts)

  1. Guido Eugenio aka Zhenya
    Member
    Posted 2 years ago #

    I've just updated to qTranslate 2.5.25 and I have got a problem. When I open a new post page to edit and publish an article I find that the content is very messed up. The same text appears in both language content areas (before it was different for each language), I mean that in the second area (to edit russian) I find also the text that I wrote in the first area (italian). In the second area text is assembled, above the italian and below the russian.

    I edit a page, add text in the italian area, then russian in its area and save.. thus I find the italian part added on top of the russian one.

    The first time this issue appears only in the Admin (frontend its all ok), but if I save again the post then I find all this extra text also in the front-end.

    Editing italian I got:
    Italian area: Italian text
    Russian area: Italian plus russian text

    At the moment the solution is:
    Before publishing one must remove all this extra text in the russian area.

    FireFox 8.0.1, FireFox 9.0.1, Opera 11.60

    http://wordpress.org/extend/plugins/qtranslate/

  2. S Johanna
    Member
    Posted 2 years ago #

    Same thing is happening to me. I upgraded to WordPress 3.3 and qTranslate 2.5.25 and when editing some pages (not all), the english version is copied at the end of the french version (default language) and sometimes more than once...

  3. dr-kos
    Member
    Posted 2 years ago #

    I have same issu - duplicating content from main langeage to all tabs on admin ui.

    nothing's help, no solution.

  4. Webartisan
    Member
    Posted 2 years ago #

    Same problem here with same updates/configurations (ITA+ENG) though v 2.5.25 solved many other important issues.

    It seems like qTranslate can't correctly split the post_content field (for <!--:it--> and <!--:en-->) and assigning the two parts to the respective istances of editor's textarea.

    I also noticed that sometimes a &nbsp; space is added at the beginning of the content.

    Sometimes content gets duplicated and pre-pended to other languages editor, sometimes it is completeley deleted.

    As for now I'using HTML editor to get rid of the problem by deleting surplus duplicated text and possibly using Revisions whenever content needs to be restored.

    Thank you

  5. Guido Eugenio aka Zhenya
    Member
    Posted 2 years ago #

    Provisional solution until the author finds a fix.. Write only in the first language textbox. Before publishing go in the html editor and add for each language the quick tags [:it] for italian, [:en] for english, [:ru] for russian and so on.

    eg:::

    [:it] <p>content italian</p>
    [:en] <p>content english</p>
  6. bhenselmann
    Member
    Posted 2 years ago #

    I found an other simple trick until the author finds a fix:

    - choose a language you don´t need as your first language.
    - Don´t use the first language tab - simply leave its content empty

  7. bhenselmann
    Member
    Posted 2 years ago #

    for not heaving an empty language on front-page simply put

    ul.qtrans_language_chooser li.lang-xx{
    display: none;
    }

    into the themes style-sheet (replace xx with the first language language-code).

  8. bhenselmann
    Member
    Posted 2 years ago #

    to hide the text area and the title for the language, you can for example use the Adminimize-plugin an put

    #qtrans_title_ja
    #qtrans_select_ja

    at "Global options" - "Your own options"

  9. Guido Eugenio aka Zhenya
    Member
    Posted 2 years ago #

    We can try the latest version 2.5.27 and see if any of the errors still occur.

  10. secretkey
    Member
    Posted 2 years ago #

    Still having the same problem, tabs with duplicate content for the secondary language, please fix that problem.

  11. Guido Eugenio aka Zhenya
    Member
    Posted 2 years ago #

    I'm convinced that qTranslate is not the cause of the problem. Suspect is the editor TinyMCE. But I will look further for the cause of this.

  12. Guido Eugenio aka Zhenya
    Member
    Posted 2 years ago #

    Well, good news. I solved the issue by changing the line 61 of qtranslate_javascript.php. (line 62 if you use qTranslate 2.5.27)

    It seems result.length on the line 94 returns "undefined ".

    I write:

    var result = new Array();

    instead of:

    var result = new Object;

    I hope this helps

  13. Guido Eugenio aka Zhenya
    Member
    Posted 2 years ago #

    Changing the "var result" code make qTranslate work, but if I embed an image through caption, then the issue is still there. As I can see the problem is always when edit a post from visual mode and the first text includes any html tag.
    This fix seems to work fine if no tags are present at the first line of the content.
    The issue looks like the tinyMCE editor loads and fix the html before qTranslate splits the content. Thus to make it working, probably need to find how to change the qTranslate load priority.

  14. visnevskis
    Member
    Posted 2 years ago #

    Is it possible to downgrade wordpress to make things work?

  15. bhenselmann
    Member
    Posted 2 years ago #

    it seems to be fixed now! Download the development version 2.5.28b2 at
    http://www.qianqin.de/qtranslate/download/

    thanks a lot, Qian!

  16. mengerg
    Member
    Posted 2 years ago #

    The translate works indeed, thanks for this update !!!
    But now I have the problem that all or most line feeds disappear in the wysiwyg editor. Typically the <p> tag is not recognized anymore.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags