WordPress.org

Ready to get started?Download WordPress

Forums

PWA+PHP Picasa Web Albums for WordPress
[resolved] images per page not working (3 posts)

  1. IanLeiman
    Member
    Posted 2 years ago #

    I have PWA+PHP pro v0.9.7 on WordPress 3.4.1. (all the latest versions) on my self hosted site.
    The images per page feature is not working on any posts or pages. The short codes always show all images in an album, no matter what I set into the plugin options page, or into the shortcode.
    For example on this post:
    http://www.leiman.fi/?p=1244&page=2
    I have the short code:
    [pwaplusphp album="Underwater" images_per_page="20" ]
    and the images Per Page option at PWA+PHP Plugin Settings is 30, but on the post I get all 400 images. It apparently doesn't matter what numbers I put into images_per_page or whatever album I use, I always get everything from any album.

    http://wordpress.org/extend/plugins/pwaplusphp/

  2. smccandl
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry for the slow reply -- wordpress.org doesn't send any notification when someone asks a question so I ask that you submit all questions @ http://pwaplusphp.smccandl.net/support.

    The behavior you've described is working as designed, but you can change it.

    If you specify an album name, the code assumes you don't want to paginate so it turns that off. You can modify the behavior by commenting out the if/else block starting on line 106 of showAlbumContents.php:

    #----------------------------------------------------------------------------
    # VARIABLES FOR PAGINATION
    #----------------------------------------------------------------------------
    #if ($IN_POST == "TRUE") {
    # $IMAGES_PER_PAGE = 0;
    #} else if ($IN_POST == "SLIDESHOW") {
    # $IMGMAX = "d";
    # $SHOW_IMG_CAPTION = "SLIDESHOW";
    #}

  3. IanLeiman
    Member
    Posted 1 year ago #

    OK, thanks.
    That patch still didn't work out for me, but I will move the issues to http://pwaplusphp.smccandl.net/support as you suggest.
    I had some issues creating the account there, as the password that was emailed to me went to junk, and I thought I wasn't getting any.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.