WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: ProPlayer] Fatal error with curl_init() in F:\web\oliwp\wordpress\w (6 posts)

  1. grosbouff
    Member
    Posted 4 years ago #

    Hi,
    I'm under WordPress 2.8.2 and I got an error with ProPlayer for every video :

    Fatal error: Call to undefined function curl_init() in F:\web\oliwp\wordpress\wp-content\plugins\proplayer\video-sources\

    File can be
    \youtube.php,
    \vimeo.php,
    ...

    What can I do ? I never ran ProPlayer before...

  2. grosbouff
    Member
    Posted 4 years ago #

    PS : it does not do it on the remote side, just in local.
    I'm under WAMP5 in local.

  3. isa.goksu
    Member
    Posted 4 years ago #

    @grosbouff, you need to enable cURL libraries/extension. Just go to your php.ini and enable the extension.

    Isa

  4. dentstu
    Member
    Posted 4 years ago #

    Hello, isa.goksu

    Can u please tell me where is php.ini? and where do I enable the extension...

  5. dentstu
    Member
    Posted 4 years ago #

    OK I found it... If anybody else is interested, here is what I did...
    Start >> Run >> type php.ini and hit enter.

  6. NativePaul
    Member
    Posted 4 years ago #

    I am so glad I found this post! I've spent two days trying to get ProPlayer to work on my local wamp testing sever.

    I'm not sure if it was necessary but I went through the hassle of installing libxml according to the steps I found here. I was so bleak when that didn't work.

    Now I just removed a ; from my php.ini file and it works!

    An easy way to get to your php.ini in wamp is to click on the wamp icon in the system tray then select PHP and php.ini is in the menu there.

Topic Closed

This topic has been closed to new replies.

About this Topic