WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: ProPlayer] fatal error (12 posts)

  1. indianwhistlers
    Member
    Posted 4 years ago #

    WordPress version: 2.8.5

    getting error on activation

    Parse error: syntax error, unexpected '{' in /homepages/45/d239642000/htdocs/WPVideoblog/wp-content/plugins/proplayer/content-handler.php on line 80

    http://wordpress.org/extend/plugins/proplayer/

  2. existonline
    Member
    Posted 4 years ago #

    Yeah, I've got WP 2.8.5 too and getting a very similar error!
    I'm trying to activate version 4.7.6 of the ProPlayer plugin.
    Someone please help us :(

    Plugin could not be activated because it triggered a fatal error.

    Parse error: parse error, unexpected ']', expecting '(' in /wp-content/plugins/proplayer/pro-player.php on line 65

  3. existonline
    Member
    Posted 4 years ago #

    Update: I just upgraded to WP 2.8.6 and I'm STILL getting that same error!

    I logged out and logged back in and tried again - same error!

    Not having much luck with this... It's a real shame... this ProPlayer plugin looks really powerful, but it doesn't want to activate for starters!

    Any help would be much appreciated.

    Cheers,
    EO

  4. isa.goksu
    Member
    Posted 4 years ago #

    @existonline, some people started to get this error. I can't reproduce. I think it's hosting related. I believe you guys have some sort of limitation on static keywords in PHP. The code on line 65 is pretty simple array access. So far 3 people reported same issue.

    Could you check your phpinfo() if there is any limitation there?

    Best,
    Isa

  5. existonline
    Member
    Posted 4 years ago #

    @isa.goksu - Thanks for looking into this for us.

    Sorry, do you know where I can find my phpinfo() file?

  6. freshwidows
    Member
    Posted 4 years ago #

    Same for me, just on the admin panel i get when i want to activate it :

    Parse error: syntax error, unexpected ']', expecting '(' in pro-player.php on line 65

    i have reinstalled the plugin after a purge on my ftp and in the table in the Db but same message.

    My server runs on that config
    Database Type MYSQL
    Database Version v5.0.51a-3ubuntu5.4-log

    Anyway thks to your plugin!
    Antoine

  7. isa.goksu
    Member
    Posted 4 years ago #

    Hi all,

    I answered this question actually in my blog. Let me quickly rephrase. Basically your hosting company is limiting STATIC keyword usages in PHP for (I guess) security reasons. You should talk to them and ask for some help. I believe you can resolve by playing with .htaccess file.

    Best,
    Isa

  8. Lorenzo dev
    Member
    Posted 4 years ago #

    Hello,

    i try proPlayer and i have this error : Parse error: syntax error, unexpected ']', expecting '(' in /mnt/129/sdb/6/f/web.codeur/wp-content/plugins/proplayer/pro-player.php on line 65

    after looking the proplayer.php and constants.php files, it seems that the author make mistake between PHP4 & PHP5.

    the guys who have this error use PHP4.

    if you don't want this error, you need to upgrade to PHP5 or make a lot of modification in the proplayer php files ->

    1. delete the Constant class
    2. replace each variables in "constants.php" by a define()
    3. make all modifications in files calling Constant variable
  9. isa.goksu
    Member
    Posted 4 years ago #

    @lorenzo, I don't get what you mean by mistake in PHP4 & PHP5? AFAIK, PHP4 supports static keywords. Those constants should be directly accessible from anywhere. It must be something else?

    But then again replacing constants with define sounds logical. 10x for the tip.

    Isa

  10. brightsoo
    Member
    Posted 4 years ago #

    I also encountered this error:

    Parse error: parse error, unexpected ']', expecting '(' in /wp-content/plugins/proplayer/pro-player.php on line 65

    BUT I eventually solved it, and thought I'd share it here. I'm on WP 2.8.6 and installed ProPlayer 4.7.7. My host is 1and1 and my WP is installed on a subdirectory and subdomain. Basically, the problem was with PHP4 vs 5.

    Having read "Is there a PHP 4 support?" in the ProPlayer FAQ, I wanted to see if my host supported PHP5 (I don't know anything about PHP), so I checked according to my host's instructions, which gave this page on my site, which at that time told me my site was 4.9.something.

    So I had thought the problem was that I couldn't run PHP5. But I thought I'd try my host's instructions on using PHP5 anyway, and it worked!

    Note I didn't use PermaLinks so I had to create the .htaccess file. Also, after creating the .htaccess file, reloading wp-admin gave an error page, the contents of which I have now forgotten... Anyway, in a bit of shock, I timidly went to my site and clicked on admin, and voila, everything is back to normal, even ProPlayer is installed! By the way, that page on my site now says I'm on 5.2.11. Go figure.

    Correction: Actually I remember having to activate ProPlayer (of course) after creating the .htaccess file. But I forgot whether the error page mentioned above came before or after activation.

  11. tristans
    Member
    Posted 3 years ago #

    Can also confirm that PHP 5 works, while PHP 4 on Media Temple hosting creates the same error.

  12. dorono
    Member
    Posted 3 years ago #

    I had the issue on MediaTemple and was able to fix it by going into my MediaTemple control panel and under PHP settings switching from PHP 4 to PHP 5, deleting the plugin, uploading again, and activating.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags