WordPress.org

Ready to get started?Download WordPress

Forums

Proper Network Activation
[resolved] Why is this functionality not in WordPress core? (11 posts)

  1. Erlend Sogge Heggen
    Member
    Posted 2 years ago #

    Been evaluating multisite for a while and.., this plugin just seems like such an essential fix. Any particular reason why it's not in WordPress core yet?

    http://wordpress.org/extend/plugins/proper-network-activation/

  2. scribu
    Member
    Plugin Author

    Posted 2 years ago #

    You can read the discussion here:

    https://core.trac.wordpress.org/ticket/14170

  3. Sebastian Cork
    Member
    Posted 2 years ago #

    @scribu: Based on my reading of the WordPress Core Trac dsicussion you linked to above, I understand that this issue has been fixed since 3.1? Just confirming.

  4. scribu
    Member
    Plugin Author

    Posted 2 years ago #

    No, it has not. The only change was that the callback to register_activation_hook() receives a boolean $network_activation parameter.

  5. marikamitsos
    Member
    Posted 2 years ago #

    @scribu: Since 3.3 is just around the corner, has this been really addressed for 3.3?
    Meaning, would that make your plugin become "obsolete" and when will that be?

  6. scribu
    Member
    Plugin Author

    Posted 2 years ago #

    Again, this has not been adressed in 3.3 and there are no definite plans for addressing it.

    Therefore, the plugin is still needed.

  7. Sebastian Cork
    Member
    Posted 2 years ago #

    @scribu: Good to know. I'm installing it now.

  8. zzzmuzz
    Member
    Posted 2 years ago #

    I installed this just now. It made no difference that I can see? I still get

    Broken Link Checker installation failed. Try deactivating and then reactivating the plugin

    Also on the sites, only a few plugins are visible.

  9. marikamitsos
    Member
    Posted 2 years ago #

    3.4 is out and looking great. :)
    So, without further ado:

    Again, this has not been adressed in 3.3 and there are no definite plans for addressing it.

    Therefore, the plugin is still needed

    Is this still true for 3.4? Is it still needed?

  10. scribu
    Member
    Plugin Author

    Posted 2 years ago #

    Let's just say that when it's not needed anymore, I'll let you know, ok? :P

  11. marikamitsos
    Member
    Posted 2 years ago #

    hahaha
    Sorry for busting your ears scribu.

    Let's just say that when it's not needed anymore, I'll let you know, ok? :P

    Fair enough. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic