WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Profile Pic] Can't upload picture, Is it Work on 2.7? (28 posts)

  1. pr3nj4k
    Member
    Posted 5 years ago #

    Hello,
    I'm upgrade my WP to 2.7 version
    And I can't upload picture into my profile or as admin or while editting my author blog.

    Thanks

  2. kReEsTaL
    Member
    Posted 5 years ago #

    Same problem here in 2.7 :(

  3. Lee Rickler
    Member
    Posted 5 years ago #

    Yup. Here as well.
    Everything else works fine but no matter what permissions/ settings I give the profile pics folder/ files nothing loads, just the default.jpg

    Also, how do you get a list of members/ authors?

  4. Cerebral ideas
    Member
    Posted 5 years ago #

    This seems to be the only post author plugin that does what I need, yet I can't get any images to upload. I have tried everything. Someone, please help!

  5. latitudes
    Member
    Posted 5 years ago #

    Okay folks, I'm working on 2.7 compatibility this weekend. hold tight :)

  6. latitudes
    Member
    Posted 5 years ago #

    2.7 compatible version is available at http://wordpress.org/extend/plugins/profile-pic/

  7. Lee Rickler
    Member
    Posted 5 years ago #

    Hi Hannah,
    Thanks for updating.

    Just installed, went to upload an image and got this error:

    Warning: Invalid argument supplied for foreach() in /home/user/public_html/wp-content/plugins/profile-pic/profile-pic.php on line 365

    Warning: Cannot modify header information - headers already sent by (output started at /home/user/public_html/wp-content/plugins/profile-pic/profile-pic.php:365) in /home/user/public_html/wp-includes/pluggable.php on line 850

  8. latitudes
    Member
    Posted 5 years ago #

    hrm I've had another user with the same error, but i can't reproduce it. could you give me more info? specifically, what version of PHP is your server running and what version of wordpress do you have?

    Thanks

  9. latitudes
    Member
    Posted 5 years ago #

    and also, what, (if any) profile display options do you have selected (ie. those first name / last name / nick name / etc checkboxes)? does the error go away if you select some or all of the checkboxes?

    Thanks!

  10. digg
    Member
    Posted 5 years ago #

    I'm having the same problem. If none of the display options are selected I get the same error (different line numbers).

  11. dwellgo
    Member
    Posted 5 years ago #

    I'm having that same problem, but running WP 2.6.5. I installed profile pic out of the box and have configured with the following:

    Multiple Authors
    Author Template Override: Yes

    and have ensured that the /wp-content/profile-pics/ dir is 777

    Here's the error that I get:

    Warning: Invalid argument supplied for foreach() in /var/www/localhost/htdocs/realestatehowto/wp-content/plugins/profile-pic/profile-pic.php on line 355

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/localhost/htdocs/realestatehowto/wp-content/plugins/profile-pic/profile-pic.php:355) in /var/www/localhost/htdocs/realestatehowto/wp-includes/pluggable.php on line 770

    Any ideas?

  12. latitudes
    Member
    Posted 5 years ago #

    I'm thinking this has to do with the way php handles globals. I made some changes in this last release (0.9.1) which will hopefully address the problem. If not... someone who is willing to be my guinea pig, please email me at bugs@geekgrl.net -- since I can't reproduce the problem, I can't test to see for sure if I've fixed it.

  13. digg
    Member
    Posted 5 years ago #

    I'm still having the same problem. I can't figure out what's causing it.

  14. pablofb
    Member
    Posted 5 years ago #

    I'm having the same problem. I use WP 2.7 and the error I get is this:

    Warning: Invalid argument supplied for foreach() in /home/s025306c/public_html/wp-content/plugins/profile-pic/profile-pic.php on line 422

    Warning: Cannot modify header information - headers already sent by (output started at /home/s025306c/public_html/wp-content/plugins/profile-pic/profile-pic.php:422) in /home/s025306c/public_html/wp-includes/pluggable.php on line 850

    And there is another problem: The pages of the authors are always empty, no matter what you select. The image also goes blank.
    But I get all (obviously all!) data and even images if I take away this:

    <?php
    $atts = array('callmethod' => 'shortcode', 'userid' => $authid);
    echo profilepic_gui_printprofile($atts);
    ?>

    By the way, thanks for plugin!!

  15. zukny
    Member
    Posted 5 years ago #

    any luck anyone?

    When i upload a photo, it shows that there has been something uploaded, it just doesnt show the picture

  16. choppingblock
    Member
    Posted 5 years ago #

    Same error here, just installed v2.7 and the latest Profile Pic plugin:

    Warning: Invalid argument supplied for foreach() in /Users/[snip]/BLOG/svn/deploy/wp-content/plugins/profile-pic/profile-pic.php on line 422
    
    Warning: Cannot modify header information - headers already sent by (output started at /Users/[snip]/BLOG/svn/deploy/wp-content/plugins/profile-pic/profile-pic.php:422) in /Users/[snip]/BLOG/svn/deploy/wp-includes/pluggable.php on line 850
  17. seg
    Member
    Posted 5 years ago #

    In reference to the error message, I found that this only happens when when none of the profile check boxes are checked at the time of updating a profile. To fix the problem, in profile-pic.php, I changed lines 422 through 424 from this:

    foreach ($raw_data as $key => $val) {
    		$reversed_data[$val] = $key;
    	}

    To this:

    if(is_array($raw_data)) {
    		foreach ($raw_data as $key => $val) {
    			$reversed_data[$val] = $key;
    		}
    	}

    That seemed to work for me!

  18. aahhh82
    Member
    Posted 5 years ago #

    I'm also not able to get any photos to upload. It acts like it uploads the photo but when it reloads the profile page it just shows the no image red x. When I check the profile-pics folder on the server, there are no photos in the foler at all.

    Did anyone figure out what was going wrong?

  19. zukny
    Member
    Posted 5 years ago #

    Im not sure if this really helps anyone else out, but this was a mistake by me.
    Im using 2.7 and I was able to upload pictures, but the pictures werent showing up.

    I changed the settings in the server to be 777 for the folder, and then when the images were being uploaded .. they were being uploaded @ 600.. i went in and adjusted them to 777 .. and now im good.

    What im saying, is
    I log in to my server, goto userphoto folder, change permissions to 777 for pictures and folder.

    Now i just have to figure out how to show the image in the comments area

  20. seg
    Member
    Posted 5 years ago #

    "Now i just have to figure out how to show the image in the comments area"

    Look at Template Tag 4 on this page:
    http://wordpress.org/extend/plugins/profile-pic/other_notes/

  21. zukny
    Member
    Posted 5 years ago #

    hey mabye you can help me, with that. I have tried placing that code in my comments area. I have been able to get the pictures to show up with the example, but they dont go into the correct location.

    here is my code. It would be awesome if you can help.

    <?php
    $email = $comment->comment_author_email;
    $default = "http://roam2rome.com/wp-content/uploads/2008/07/avtar11.gif"; // link to your default avatar
    $size = 52; // size in pixels squared
    $rating = "PG"; // [G | PG | R | X]
    $grav_url = "http://www.gravatar.com/avatar.php?gravatar_id=
    " . md5($email) . "&default=" . urlencode($default) . "&size=" . $size."&rating=".$rating;
    ?>
    
    <div class="comment_user<?php echo $commentalt; ?>">
    <div class="user_avatar"><img src="<?=$grav_url ?>" height="<?=$size ?>" width="<?=$size ?>" alt="User Gravatar" /></div>
    <div class="user_infos">
    <div class="com_author"><?php comment_author_link(); ?> said in <?php comment_date('F jS, Y') ?> at <?php comment_time() ?> <?php edit_comment_link('edit','',''); ?></div>
    <div class="com_text"><?php comment_text() ?></div>
    </div>
    </div>
    <div class="com_break"></div>'
  22. timsteen
    Member
    Posted 5 years ago #

    hello,

    I was encountering the same errors as bigbadboy.

    the fix from seg seemed to fix that for me.

    However, when viewing the site, the dynamic author page (with multiple authors) was coming up blank, with no bio info or profile pic. When I had the user add a post to the site, then the bio and the pic appeared.

  23. wowcoolstuff
    Member
    Posted 5 years ago #

    I'm and using WP to 2.7+
    In user accounts picture will not load. - Everything else works.

    Please help. Its a great plugin, and I want to donate but I need the picture to work.

  24. ashflash
    Member
    Posted 5 years ago #

    I too just upgraded my WP to 2.7 version.
    This is what I get when I try to upload my bio pic.

    Warning: main(/home/public_html/blog/wp-content/wp-config.php) [function.main]: failed to open stream: No such file or directory in /home/public_html/blog/wp-content/themes/prophoto2/prophoto2/adminpages/popup.php on line 11

    Fatal error: main() [function.require]: Failed opening required '/home/public_html/blog/wp-content/wp-config.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/public_html/blog/wp-content/themes/prophoto2/prophoto2/adminpages/popup.php on line 11

    Everything else seems to be ok so far.
    Anyone know what the prob. is?

  25. groovysoul
    Member
    Posted 5 years ago #

    Everything worked until I changed one of the authors of a post. Now only the admin photo and info shows in the widget. I really can't understand why.

    It happened in my first attempt at this blog. http://www.groovysoulcreative.com/customers/beta/hoophound/

    Then I remade the blog entirely, http://www.groovysoulcreative.com/hoophound/beta/

    I added all the plugins I needed, added the widgets, everything worked. Then I changed the author on one post and it no longer hooks to the author.

    I've even deactivated all plug-ins but Profile Pic, but the functionality won't come back.

    Does anyone have an idea how to fix this? It's such a great plug-in when it works!

  26. groovysoul
    Member
    Posted 5 years ago #

    I hate to be a spoiler of any kind, because I love the idea of this plug-in, but I just installed Author Avatars http://wordpress.org/extend/plugins/author-avatars/ and it did pretty much all I need. Just be sure to check no in the Profile Pic settings before you disable it.

    General Stuff > 'Gravatar'/Avatar Override: Yes No

    Then you can use Gravatars. It's not as slick as using a photo specific to your blog, but it works.

  27. martinixmix
    Member
    Posted 5 years ago #

    Awesome, Seg's bug fix worked.

    For those with this issue, scroll up to Seg's comment and follow his/her instructions. I just did it with mine and it's good now.

  28. eampiart
    Member
    Posted 4 years ago #

    AWESOME!

    Thank you Seg!!

    I'm using a modded Profile Pic (0.9.2), it doesn't shows the check boxes, and WP 2.8.4, and that instructions are still working!

    Thank you again Seg!

Topic Closed

This topic has been closed to new replies.

About this Topic