WordPress.org

Ready to get started?Download WordPress

Forums

Private! WordPress Access Control Manager
[resolved] Several hundred lines of Warning Errors (9 posts)

  1. bamajr
    Member
    Posted 3 years ago #

    After following the directions to install your plug-in I went to the configuration page. Directly under the section title of "More details about allowed/forbidden areas" I got several hundred lines of the same error message. Error shown below:

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/bamajr.com/public_html/wp-content/plugins/private-wordpress-access-control-manager/lib/xfw_private.class.php on line 335

  2. X-Blogs
    Member
    Plugin Author

    Posted 3 years ago #

    Should be fixed in 1.1.1! Thank you!

    I uploaded the new version minutes ago. Please update, when possible and tell me, if the errors are gone. :-)

  3. bamajr
    Member
    Posted 3 years ago #

    The errors are definitely gone. I like the security of your plug-in. Great job.

    I have a question though. I want my web site and blog to be wide open to everyone, except I want to force visitors to register in order to comment, and I want to restrict access to a specific set of pages to people who are logged in and are of the administrative group.

    Can your plug-in accomplish any of this?

  4. X-Blogs
    Member
    Plugin Author

    Posted 3 years ago #

    Force visitors for commenting is a build in feature in WordPress. You can activate it under Options > Discusssion. If you want to restrict access to specific pages, the easiest way is to so is to add these pages under a special category or tag, activate the plugin, deactivate time-based auth, change the role as desired (author or whatever), allow access to all kind of pages, and than restrict the access to your special category.

    Currently I'm adding some kind of assistant to the plugin, as it is not that easy to configure safely.

  5. hdridder
    Member
    Posted 3 years ago #

    I installed and activated the plugin (version 1.2.1) today from the WP-plugin interface.
    In the Private! configuration page I get several messages like below.
    The plugin seems to be working fine though.

    Warning: Missing argument 8 for xfw::form_row(), called in /volume1/www/wp_proj/wp-content/plugins/private-wordpress-access-control-manager/lib/xfw_private.class.php on line 399 and defined in /volume1/www/wp_proj/wp-content/plugins/private-wordpress-access-control-manager/lib/xfw.class.php on line 44.

  6. X-Blogs
    Member
    Plugin Author

    Posted 3 years ago #

    Fixed in 1.2.2 - Thank you!

  7. hdridder
    Member
    Posted 3 years ago #

    Incredible fast support!!!
    I upgraded my vote from great to fantastic.

    1 minor remark. If time based approvement is used, the comment in the 'User Profile'-'Private! options' is in German. I think it should be English.

  8. X-Blogs
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks again, I fixed this. Next version will be there in few hours. I first want to complete the assistant. :-)

  9. X-Blogs
    Member
    Plugin Author

    Posted 3 years ago #

    1.3.0 is up!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic