WordPress.org

Ready to get started?Download WordPress

Forums

Private Suite
Fixing prefix for "Private: " and "Protected: " (1 post)

  1. maxemil
    Member
    Posted 3 years ago #

    This really cool plugin "Private Suite" had a bug for me.

    The included function for substituting the prefix for "Private: " and "Protected: " diden't work, and simply inserted yet another text before the "Private: " text - and did not substite it with my entered value.

    Thus I have made a small change:

    function private_suite_custom_private_title($s) {
    	$options = get_option('private_suite');
    //	$s = str_replace(__("Private:"), '', $s);
        $s = '%s';
    	return stripslashes($options['private_title_prefix']).$s;
    }
    
    add_filter('protected_title_format', 'private_suite_custom_protected_title');
    function private_suite_custom_protected_title($s) {
    	$options = get_option('private_suite');
    //	$s = str_replace(__("Protected: "), '', $s);
        $s = '%s';
    	return stripslashes($options['protected_title_prefix']).$s;
    }

    Best Regards.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

  • RSS feed for this topic
  • Started 3 years ago by maxemil
  • This topic is not a support question
  • WordPress version: 3.0