WordPress.org

Ready to get started?Download WordPress

Forums

Print Friendly and PDF Button
Remove Dashed Line/Header (23 posts)

  1. colewebdev
    Member
    Posted 2 years ago #

    I'd like to remove/hide the pf-src div from the print window so it does not display in the PDF.

    I tried adding the following to my stylesheet but it had no effect:

    <style type="text/css">
    .pf-src {visibility:hidden;}
    </style>

    What I'm shooting for is to have just the content of the post print, and nothing else. Can this be done? The CSS file seems to be sourced from a CDN and not included within the plugin.

    http://wordpress.org/extend/plugins/printfriendly/

  2. Svennoz
    Member
    Posted 1 year ago #

    Did you ever find a solution to this ? I'm also looking for this.

  3. acmb3
    Member
    Posted 1 year ago #

    try:
    .pf-src {display: none}

    Not sure if that's the right class just going off of what you put above.

    Also, make sure your adjustment (css) loads AFTER the plugins css. CSS is read from the top down, so if they define "display: block" within the plugins css your code will have no affect.

    Lets see if that helps. :)

  4. Svennoz
    Member
    Posted 1 year ago #

    I tried

    .pf-src {display: none}

    But it didn't work, but I don't know how I can make my adjustments load after the plugin css.

  5. acmb3
    Member
    Posted 1 year ago #

    Post a link to your site so I can see please. :)

  6. Svennoz
    Member
    Posted 1 year ago #

  7. acmb3
    Member
    Posted 1 year ago #

    Give this a try:
    #pdf {display: none;}

  8. Svennoz
    Member
    Posted 1 year ago #

    Unfortunately that doesn't work either :(

  9. acmb3
    Member
    Posted 1 year ago #

    I looked a bit further into this plugin and it looks to be hosted by the provider (3rd party). No wonder our changes don't take affect. :)

    Okay, here is what I want you to do.

    #1. Go to your FTP and open the script "pf.php". You should be able to find it here: "wp-content/plugins/printfriendly/pf.php".

    #2. Go to line 223 (should be around there). You are looking for these:

    var pfHeaderImgUrl = "<?php echo $image_url ?>";
    var pfHeaderTagline = "<?php echo $tagline ?>";
    var pfdisableClickToDel = "<?php echo $this->options['click_to_delete'] ?>";

    #3. Add this below the last option:
    var pfDisablePDF = 1;

    #4. Save the file and give it a try! This should remove the PDF option from the pop-up now properly.

  10. acmb3
    Member
    Posted 1 year ago #

    If you are unsure how to do that just hit up my contact form on moonbase3.com and send your FTP details - I can go in and fix it up. :)

  11. Svennoz
    Member
    Posted 1 year ago #

    yes it does delete the PDF but I think we misunderstood each other somewhere along the lines.
    What I'm trying to do is remove the URL from the site in the print friendly page, this part.

    http://d.pr/i/kfXh

  12. Svennoz
    Member
    Posted 1 year ago #

    Any idea's ?

  13. acmb3
    Member
    Posted 1 year ago #

    Howdy,

    Sorry lost track of this topic.

    This one is a bit more complicated.

    FIRST create a css file and save it on your website with this in it:

    .pf-src-name {display: none;}
    .pf-src-url {display: none;}

    SECOND add the below variable just like I had you do the PDF one above:

    var pfCustomCSS = 'http://www.YOURSITE.com/css_file.css';

    Change the url to your site and the style sheet you just created - where ever you loaded it.

    Give it a try :)

  14. Svennoz
    Member
    Posted 1 year ago #

    You sir, are my superhero.
    I've spend so much time searching for this and now thanks to you it works!
    You have my eternal gratitude :D

  15. Svennoz
    Member
    Posted 1 year ago #

    Might I impose you a little more with 1 more question?

    If yes, read on.
    If no, have a pleasant day :D

    Question:
    Next to Print,PDF,E-mail, Should be text size, delete image and undo. For some reason they are algined underneath the print,pdf,email. I tried repositioning and resizing the text, in my chrome inspect element it works, but when I add it to the custom css file I made (with your help) it's not working.
    Any idea's ?

  16. acmb3
    Member
    Posted 1 year ago #

    Howdy,

    It is showing up properly for me - can you take a screenshot and also post the code you put in the css so I can see. :)

  17. Svennoz
    Member
    Posted 1 year ago #

    Screenshot: http://d.pr/i/a91F

    Tried this css: .pf-toolbar .pf-options {font-size: 10px;}

    and some other things, but i've override them.

  18. Svennoz
    Member
    Posted 1 year ago #

    Btw, only in IE (8) is it working correctly, in Chrome/FF/Safari it's not showing up, usually it's the other way around :P

  19. acmb3
    Member
    Posted 1 year ago #

    Hrm.. Not sure - it is working fine for all of those browsers for me. Try a few products, maybe something in the product itself is throwing it off.

  20. Svennoz
    Member
    Posted 1 year ago #

    Well I tried several different product, but they all are not showing it, tried it at a different pc here at the office with chrome and IE (9). Chrome wasn't showing it and IE was showing it, really weird. I'll check it at home tonight if that makes a difference.

  21. Svennoz
    Member
    Posted 1 year ago #

    Very odd, at home I don't see those buttons either.

  22. printfriendly
    Member
    Plugin Author

    Posted 1 year ago #

    We've recently launched custom styles and the ability to include custom CSS.

    Currently these features are only available with the print friendly & pdf button code found at http://www.printfriendly.com/button.

    We'll be releasing a new plugin soon that will include.

  23. Svennoz
    Member
    Posted 1 year ago #

    That's good to hear :D

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.