WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] Plugin preventing access to wp-admin (7 posts)

  1. dizziness
    Member
    Posted 9 months ago #

    I recently re-activated EWWW after being disabled for a while. After re-activating, I cannot access my /wp-admin. /wp-login.php is available but my browsers hang. Watching the server, here's the commands being executed during the hang:

    2860 cgillesp  22   2 18996 1268  984 R   73  0.0   0:00.14 top -c
     2721 cgillesp  20   0 17500 1344 1116 D    0  0.0   0:00.01 sh -c file -v 2>&1
     2837 cgillesp  22   2 68440 1584  880 S    0  0.0   0:00.01 sshd: cgillespie@pts/0
     2843 cgillesp  22   2  121m 1972 1480 S    0  0.0   0:00.01 -bash
     2854 cgillesp  20   0 17500  228    0 R    0  0.0   0:00.00 sh -c file -v 2>&1
    18537 cgillesp  20   0  246m  58m 9052 S    0  0.2   0:21.13 php53.cgi
    21317 cgillesp  22   2 68424 1684  980 S    0  0.0   0:00.02 sshd: cgillespie@notty
    21358 cgillesp  22   2 12356  904  696 S    0  0.0   0:00.02 /usr/lib/openssh/sftp-server
    24665 cgillesp  30  10  240m  53m 9440 S    0  0.2   1:42.89 php53.cgi

    Once it bounces to my 404 page, the next attempt to reload the dashboard gives these results:

    2860 cgillesp  22   2 18996 1268  984 R    0  0.0   0:00.39 top -c
     2759 cgillesp  20   0  232m  45m 8156 S    0  0.1   0:02.99 php53.cgi
     2837 cgillesp  22   2 68440 1584  880 S    0  0.0   0:00.01 sshd: cgillespie@pts/0
     2843 cgillesp  22   2  121m 1972 1480 S    0  0.0   0:00.01 -bash
     3001 cgillesp  20   0  245m  56m 8604 D    0  0.2   0:03.14 php53.cgi
     3066 cgillesp  20   0 17524 1344 1112 D    0  0.0   0:00.00 sh -c  /home/cgillespie/outerrimterritories.com/wp-content/ewww/jpegtran -v /home/cgillespie/outerrimterritories.com/wp-content/plugins/ewww-image-optimizer/sample.jpg 2>&1
     3166 cgillesp  20   0 17524  232    0 R    0  0.0   0:00.00 sh -c  /home/cgillespie/outerrimterritories.com/wp-content/ewww/jpegtran -v /home/cgillespie/outerrimterritories.com/wp-content/plugins/ewww-image-optimizer/sample.jpg 2>&1
     3211 cgillesp  20   0  245m  48m  356 R    0  0.2   0:00.00 php53.cgi
    21317 cgillesp  22   2 68424 1684  980 S    0  0.0   0:00.02 sshd: cgillespie@notty
    21358 cgillesp  22   2 12356  904  696 S    0  0.0   0:00.02 /usr/lib/openssh/sftp-server

    Via SSH, when I execute the command for jpegtran, I get this:

    Independent JPEG Group's JPEGTRAN, version 9  13-Jan-2013
    Copyright (C) 2013, Thomas G. Lane, Guido Vollbeding
    Start of Image
    JFIF APP0 marker: version 1.01, density 72x72  1
    Define Quantization Table 0  precision 0
    Define Quantization Table 1  precision 0
    Start Of Frame 0xc0: width=5, height=5, components=3
        Component 1: 2hx2v q=0
        Component 2: 1hx1v q=1
        Component 3: 1hx1v q=1
    Define Huffman Table 0x00
    Define Huffman Table 0x10
    Define Huffman Table 0x01
    Define Huffman Table 0x11
    Start Of Scan: 3 components
        Component 1: dc=0 ac=0
        Component 2: dc=1 ac=1
        Component 3: dc=1 ac=1
      Ss=0, Se=63, Ah=0, Al=0
    End Of Image
    ????JFIFHH??C??C?"??
    
    ???}!1AQa"q2??#B??R??$3br?
    %&'()*456789:CDEFGHIJSTUVWXYZcdefghijstuvwxyz???????????????????????????????????????????????????????????????????????????
    
    ???w!1AQaq"2B????	#3R?br?
    $4?%?&'()*56789:CDEFGHIJSTUVWXYZcdefghijstuvwxyz??????????????????????????????????????????????????????????????????????????
                                                                                                                              ????(?????

    I'm guessing that this jpegtran command is hanging the system. How can I reset the system?

    http://wordpress.org/plugins/ewww-image-optimizer/

  2. nosilver4u
    Member
    Plugin Author

    Posted 9 months ago #

    actually, jpegtran is not likely to cause php to hang. What version of the plugin do you have installed?

  3. dizziness
    Member
    Posted 9 months ago #

    1.7.1 is installed. I deleted, let WordPress disable, and was able to reach the Dashboard. Reinstalled via download and FTP, activated, and login hangs again.

  4. nosilver4u
    Member
    Plugin Author

    Posted 9 months ago #

    The only thing I've come across that does such a thing is having a function that EWWW IO uses in the disable_functions list of the 'suhosin' mod for php. Can you try this:

    Create a file called info.php with these contents on your server:

    <?php phpinfo(); ?>

    Then post the url to that file here.

  5. dizziness
    Member
    Posted 9 months ago #

    Interesting. It might be a server issue as I'm running the same plugin on the same box for another domain. And it is hanging on login, too.

    http://outerrimterritories.com/info.php

  6. nosilver4u
    Member
    Plugin Author

    Posted 9 months ago #

    I don't see anything obvious there, re-activate it, and then check your server error logs to see what might be going on.

  7. nosilver4u
    Member
    Plugin Author

    Posted 9 months ago #

    marking as 'resolved' after one week of inactivity, if you have anything to add (resolution or otherwise), please feel free to respond and I can re-open the thread.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.