WordPress.org

Ready to get started?Download WordPress

Forums

Posts 2 Posts
[resolved] connecting other built in types not working (3 posts)

  1. obvio
    Member
    Posted 3 years ago #

    thanks for a really great plugin! i know I just have to use it in my next project.
    some problem I'm getting and issue with is trying to connect post with attachments, for example (version 0.2):

    function my_connection_types() {
            p2p_register_connection_type('post', 'page');//that works!
    	p2p_register_connection_type('post', 'attachment');//that doesnt work..
    }
    add_action('init', 'my_connection_types', 100);

    this issue also exists with revisions and menu_nav_items, a real handy addon would be something like a "show all for possible posts under this type" button in the meta box on the edit post/page screen.

    I'll just add that the meta box appear on the edit page and looks to be working (it does the ajax calls) but never returns anything. it doesn't also if it's the only one unique box on that page (only 1 declared in functions.php).

    thanks a lot!

  2. scribu
    Member
    Plugin Author

    Posted 3 years ago #

    some problem I'm getting and issue with is trying to connect post with attachments, for example

    This has been fixed in the development version (0.2.1-alpha).

    a real handy addon would be something like a "show all for possible posts under this type" button in the meta box on the edit post/page screen.

    Yep, that's on the todo list.

  3. obvio
    Member
    Posted 3 years ago #

    thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic