WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: PostLists] Postlist plugin compatible with WP 2.8? (3 posts)

  1. DesertLynx
    Member
    Posted 5 years ago #

    I need to list the latest posts (ideally plus excerpts) on this theme I'm designing and I was hoping the " Postlists" plugin might do.

    However, when I go to install it, it doesn't appear anywhere on the dashboard that I can see. Have re-installed and read instructions to no avail.

    Am I missing something, or else is it possible to easily list the latest say... 5 posts in a theme?

  2. reneade
    Member
    Posted 5 years ago #

    try again now with the updated version! :-)
    the problem was the folder structure of the plugin: in the plugins root there are some documentation files, and a folder "postlists" containing the plugin php file. if you install it manually by uploading, it should be clear to only upload the subfolder and not the whole plugin folder with documentation pdfs and files like that, like explained in the plugins documentation. if you let wordpress do an automatic installation it stores all the files (also with documentation that is not needed there) in the wp-plugins folder, and the "postlists" subfolder is stored as a subfolder within the folder created for the plugin. therefore the plugin file itselfe is to deeph, and wordpress is not able to find it there: "wp-content/plugins/postlists/postlists/postlists.php" (should be "wp-content/plugins/postlists/postlists.php"). now i just added an forwarder to the root folder, so that wordpress will find this and includes the plugin file than. dont know how wordpress recommends to seperate documentation files...

  3. DesertLynx
    Member
    Posted 5 years ago #

    oh... I feel like a complete idiot. My sincere thanks for that.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags