WordPress.org

Ready to get started?Download WordPress

Forums

Postie
Works manually but not automatically (24 posts)

  1. RonaldMcCallum
    Member
    Posted 3 years ago #

    when I click on 'Run Postie' the email transfers to the blog,

    but..

    although the 'Mailserver' setting is set to update 'every ten minutes' this is not happening.

    I can see the email in the specified mailbox but the automated update is not happening.

    Is there something else I should set up?

  2. Steve
    Member
    Posted 3 years ago #

    Postie is a great concept.

    I have the same issue though, not sure if I've missed something?

    Also when the email is sent to the specified post by email address (then Postie is run manually) it adds it as a post but if the post by email address is used as cc or bcc it doesn't appear (even if run manually). Is it only designed to work if the address is in the to field?

  3. RavanH
    Member
    Posted 3 years ago #

    Same issue here... but on a multi-site setup.

    Although it has posted automatically ONCE when I was not looking! Very strange.

  4. jauphrwa
    Member
    Posted 3 years ago #

    Same problem!
    But it USED TO work!!!
    :-\

  5. RavanH
    Member
    Posted 3 years ago #

    so... any idea WHEN it broke? was it the upgrade to 1.4.2 maybe?

  6. jauphrwa
    Member
    Posted 3 years ago #

    I just tried with 1.4.1 (in place of current version 1.4.2) and nothing changes...

  7. RonaldMcCallum
    Member
    Posted 3 years ago #

    Hi,
    My problem is also on a multi site installation.

    Haven't found a solution yet

  8. jauphrwa
    Member
    Posted 3 years ago #

    Something weird : postie just checked my IMAP mail account. So 2 days after sending the email, my post is online (with the date and hour of the email, not today)... But it's set to check every 10 minutes!

    It works but, very very slowly! ;-)

  9. RavanH
    Member
    Posted 3 years ago #

    jauphrwa, i had that happen ONCE too... but never again since then :(

  10. jauphrwa
    Member
    Posted 3 years ago #

    Maybe the persons how said it works (WP 3.1 + Postie 1.4.2) could tell us what are their options and mail account settings (gmail, own server,...)? It could be also good to click on "Broken" button on the plugin's page : http://wordpress.org/extend/plugins/postie/

  11. jauphrwa
    Member
    Posted 3 years ago #

    Once more, it worked but : post was online today at 20:37 and email was sent yesterday on 11:53 (and the post is timestamped with the date of yesterday).
    I don't understand...

  12. jauphrwa
    Member
    Posted 3 years ago #

    Postie woke up?
    This evening I sent an email on 21:43, it was online on 22:28!

    ... very strange...

  13. jauphrwa
    Member
    Posted 3 years ago #

    Can't understand : another one sent yesterday at 22:42, online today at 8:37...

  14. jauphrwa
    Member
    Posted 3 years ago #

    Now nothing since 2 days and an email is waiting in the "Incoming mailbox"...

  15. RavanH
    Member
    Posted 3 years ago #

    Has anyone tried Crony Cronjob Manager or WP-Crontrol (which still seems to work even on 3.1 in multi-site mode!) to see if the postie cron job is listed?

    I see check_postie_hook there, corresponding with the hourly setting I configured in Postie settings... Looks OK but will test with it (deleting and adding it manually, firing it manually or what not) to find out more.

  16. jauphrwa
    Member
    Posted 3 years ago #

    Thanks for this!

    I also have

    Function 		Schedule 	Next Run 		Arguments
    check_postie_hook 	Twice per hour 	mar 9, 2011 @ 11:22 	N/A

    Postie is set "twice per hour"...

  17. tamantit
    Member
    Posted 3 years ago #

    I'm using the last release of the plugin + wp 3.1

    Scheduled post feature does not work and I see two broken links at the bottom.

    I tried this workaround:

    install crontrol
    remove the check_postie_hook scheduling
    add new check_postie_hook scheduling (I tried with twice/hour, every 10 mins, ooce a day)

    It does not work. Even if I run manually the related WP-Cron Entries, email are not imported.
    Postie works only If I run it manually (pressing the button "To run the check mail script manually").

    Any ideas?

    Many thanks

  18. tfraley
    Member
    Posted 3 years ago #

    having the same issue here. Would be nice to know why its not scheduling.

  19. glreber
    Member
    Posted 2 years ago #

    I have the same issue, will work manually but not in automode or with crone job.

  20. Chuppa
    Member
    Posted 2 years ago #

    Same as the rest of you - manual works, but not auto.

  21. glreber
    Member
    Posted 2 years ago #

    Chuppa, I ended up using a crone job pointing to the .../postie/get_mail.php. I also put a link in the footer of my page only available to admins that I can use to run the page manually if needed.

    ================================================
    <?php if (current_user_can('administrator')):?>
    Get Posts
    <?php endif; ?>

  22. Chuppa
    Member
    Posted 2 years ago #

    glreber - tried multiple times with a cron job using curl for .../postie/get_mail.php

    Still doesn't work if I manually place that addy in my address bar. Ends up loading the site - is it meant to do that?

  23. Chuppa
    Member
    Posted 2 years ago #

    Take that back - got my cron job working

    env /usr/local/bin/php /home/USENAME/folder/wp-content/plugins/postie/get_mail.php

  24. glreber
    Member
    Posted 2 years ago #

    Good that your cron is working. As for the footer it shouldn't load the get_mail.php but only be a link if the user is logged in as administrator. The if statement should only display a "Get Posts" link if the condition is met. You did put the php code with the link correct?

    I noticed above that the <a href turned into a link in the post, didn't anticipate that.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags