WordPress.org

Ready to get started?Download WordPress

Forums

PostgreSQL for WordPress (PG4WP)
[resolved] Error at WordPress installation (8 posts)

  1. mirefoot
    Member
    Posted 2 years ago #

    I get an error at wordpress insallation relating to inserting some of the start up data but then when I have logged in using the login and password I entered at the setup I then get

    You do not have sufficient permissions to access this page.

    http://wordpress.org/extend/plugins/postgresql-for-wordpress/

  2. hawk__
    Member
    Plugin Author

    Posted 2 years ago #

    Hi

    PG4WP 1.2.2 was not tested yet with WordPress 3.3.x

    However, I had reports saying PG4WP 1.2.2 works ok with WP 3.3 but I don't know if these concern fresh installs or upgrading from a previously working installation.

    I think your problem comes from the errors you got when installing.
    If using PostgreSQL 9.x, this problem may be solved by setting standard_conforming_strings = off in your postgresql.conf file.

    See this article for details.

    Hope this will help you.

  3. mirefoot
    Member
    Posted 2 years ago #

    I tried that however at instal I get the following error running on a localhost WAMP server. I have access to the dataabse using the postgresql tools so it appears to be working.

    Do I have to shut down the postgres and restart it and if so how do i do that?

    [ERROR: syntax error at or near "s" LINE 1: ...012-01-05 20:38:04','This is an example page. It\'s differen... ^]
    INSERT INTO wp_posts (post_author,post_date,post_date_gmt,post_content,post_excerpt,post_title,post_name,post_modified,post_modified_gmt,guid,post_type,to_ping,pinged,post_content_filtered) VALUES ('1','2012-01-05 20:38:04','2012-01-05 20:38:04','This is an example page. It\'s different from a blog post because it will stay in one place and will show up in your site navigation (in most themes). Most people start with an About page that introduces them to potential site visitors. It might say something like this:

    Hi there! I\'m a bike messenger by day, aspiring actor by night, and this is my blog. I live in Los Angeles, have a great dog named Jack, and I like piña coladas. (And gettin\' caught in the rain.)
    ...or something like this:
    The XYZ Doohickey Company was founded in 1971, and has been providing quality doohickies to the public ever since. Located in Gotham City, XYZ employs over 2,000 people and does all kinds of awesome things for the Gotham community.
    As a new WordPress user, you should go to your dashboard to delete this page and create new pages for your content. Have fun!','','Sample Page','sample-page','2012-01-05 20:38:04','2012-01-05 20:38:04','http://localhost/PartsLocator/?page_id=2','page','','','')

  4. mirefoot
    Member
    Posted 2 years ago #

    Here is the code correctly formatted:

    [ERROR: syntax error at or near "s" LINE 1: ...012-01-05 20:38:04','This is an example page. It\'s differen... ^]
    INSERT INTO <code>wp_posts</code> (<code>post_author</code>,<code>post_date</code>,<code>post_date_gmt</code>,<code>post_content</code>,<code>post_excerpt</code>,<code>post_title</code>,<code>post_name</code>,<code>post_modified</code>,<code>post_modified_gmt</code>,<code>guid</code>,<code>post_type</code>,<code>to_ping</code>,<code>pinged</code>,<code>post_content_filtered</code>) VALUES ('1','2012-01-05 20:38:04','2012-01-05 20:38:04','This is an example page. It\'s different from a blog post because it will stay in one place and will show up in your site navigation (in most themes). Most people start with an About page that introduces them to potential site visitors. It might say something like this: <blockquote>Hi there! I\'m a bike messenger by day, aspiring actor by night, and this is my blog. I live in Los Angeles, have a great dog named Jack, and I like piña coladas. (And gettin\' caught in the rain.)</blockquote> ...or something like this: <blockquote>The XYZ Doohickey Company was founded in 1971, and has been providing quality doohickies to the public ever since. Located in Gotham City, XYZ employs over 2,000 people and does all kinds of awesome things for the Gotham community.</blockquote> As a new WordPress user, you should go to <a href=\"http://localhost/PartsLocator/wp-admin/\">your dashboard</a> to delete this page and create new pages for your content. Have fun!','','Sample Page','sample-page','2012-01-05 20:38:04','2012-01-05 20:38:04','http://localhost/PartsLocator/?page_id=2','page','','','')
  5. mxa5942
    Member
    Posted 2 years ago #

    I am also having the same exact problem described by mirefoot. The installation succeeded, with the error described in the original post, and now I cannot access the admin area.

    I get to the login page, but once I login I get the error

    You do not have sufficient permissions to access this page.

    For what it's worth, the WordPress seems to be function properly except for the admin side of things.

    My current setup:

    $ psql --version
    psql (PostgreSQL) 9.1.3

    WordPress 3.2.1 since this version was listed as the last tested version for PG4WP).

    Any help would be appreciated!

    EDIT: I was able to login to my PostgreSQL server and re-issue the insert statement that error'd out (using the correct syntax). This didn't fix the problem. Did the initial error during install prevent some other installation tasks?

  6. mxa5942
    Member
    Posted 2 years ago #

    For anyone else having this problem, here is the current workaround:

    Before beginning the WordPress install, open up the upgrade.php file found in wp-admin/includes.

    In the file, find the function definition for wp_install_defaults() (for me, this was line 105 in WordPress 3.2.1)

    In this function, you'll find code that creates the default page (for me, this was line 258 in WordPress 3.2.1). Specifically, the line begins with $wpdb->insert( $wpdb->posts, array(. Comment the entire insert function call out and run the installer.

  7. hawk__
    Member
    Plugin Author

    Posted 2 years ago #

    Hi all

    mxa5942's workaround will resolve the installation problem itself, but you'll encouter problems using WordPress as MySQL quoting is not accepted by PostgreSQL 9.1+ without setting standard_conforming_strings = off in your postgresql.conf file.

    I'm going to work on a fix for this problem in the coming weeks, watch out for the next release :)

  8. hawk__
    Member
    Plugin Author

    Posted 2 years ago #

    I published a beta for the upcoming release of PG4WP which is mainly aimed at PostgreSQL 9.1+ support.

    You can download this version from the developers page in the plugin directory.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic