WordPress.org

Ready to get started?Download WordPress

Forums

Posterous Importer
403 error message when running (8 posts)

  1. mwill81
    Member
    Posted 2 years ago #

    I've installed and activated class-wp-importer 0.6.1 and Posterous Importer 0.8. I get this error when trying to run the importer:

    Got HTTP code 403 from http://posterous.com/api/getsites

    http://wordpress.org/extend/plugins/posterous-importer/

  2. Johanhorak
    Member
    Posted 2 years ago #

    Where you able to fix this?

  3. Daryl L. L. Houston (dllh)
    Member
    Plugin Author

    Posted 2 years ago #

    Try version 0.10, which just landed. It includes a fix that should help with 403 errors.

  4. justinkelly
    Member
    Posted 2 years ago #

  5. Johanhorak
    Member
    Posted 2 years ago #

    I created a bog at wordpress.com. There the plugin works. Imported my posterous blog and exported it. And then imported to my .org blog. What a slept but it works.

  6. Daryl L. L. Houston (dllh)
    Member
    Plugin Author

    Posted 2 years ago #

    justinkelly, maybe the sleep command isn't long enough. If you're feeling brave, edit the plugin in a text editor. Look for references to "usleep" and change the number inside parentheses so that the first digit is a 2 or even a 3 (don't go much higher than that). Usually Posterous wants you to wait a second between requests, but I suppose it's possible that in some cases it wants you to wait longer or that the timing currently built into the plugin is too close to 1 second to satisfy Posterous's limit.

  7. zecompadre
    Member
    Posted 2 years ago #

    using last version

    everytime i try to import

    "Got HTTP code 403 from http://posterous.com/api/getsites"

  8. Merry122
    Member
    Posted 1 year ago #

    Thanks dllh!
    usleep( 3100000 ); worked for me

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic