WordPress.org

Ready to get started?Download WordPress

Forums

Post Types Order
[resolved] All Nav Menus disappear after sorting (11 posts)

  1. anvithks
    Member
    Posted 2 years ago #

    I am running WP3.2 and RT Theme 13. Due to heavy customization I am not able to update the theme or WordPress to latest versions. As the plugin is supported till WP3.2.2 I assume it should not be a WP issue. When I activate the plugin and sort all the custom posts and categories, all the navigation menus disappear.
    The menus are visible when the site is loaded. After clicking on the products section the ordering is shown, but all nav menus disappear. I have read that this issue was faced by others as well. I am running a local install hence won be able to give access.
    Any known issues / fixes for this problem?

    http://wordpress.org/extend/plugins/post-types-order/

  2. tdgu
    Member
    Posted 2 years ago #

    It is known that this problem occur on themes where the menus are not defined through the internal admin (Appearance > Menus). Try to implement this feature and the issue will be gone. Or turn off the Autosort and use the menu_order along with your custom queries.

  3. anvithks
    Member
    Posted 2 years ago #

    The theme supports WP3 menus. So that may not be the root cause here. Will try what you suggested.

  4. nsp-code
    Member
    Plugin Author

    Posted 2 years ago #

    Indeed using the internal menus will fix the issue while keep the Autosort to ON

  5. anvithks
    Member
    Posted 2 years ago #

    The theme already has WP3.0 internal menus. The problem persists. I have resorted to deactivating and changing the publish dates to order the posts.

  6. nsp-code
    Member
    Plugin Author

    Posted 2 years ago #

    Can you confirm that within your Appearance -> Menus (wp-admin/nav-menus.php) you created the Menu Name and choose a selection from Theme Location on the left.
    If this still does not fixed your issue, can you please contact us at electronice_delphi@yahoo.com so we can check into this.

  7. anvithks
    Member
    Posted 2 years ago #

    Yes. That is precisely what I have done. I will contact you. Problem is I am working on local server and cannot install online until I get approval.

  8. jynk
    Member
    Posted 1 year ago #

    Same problem here - menu disappears after activating plugin.

  9. nsp-code
    Member
    Plugin Author

    Posted 1 year ago #

    Do you use the Menus feature (admin) and you have created those and assigned to theme location ?

    If you still have issues please contact us at electronice_delphi@yahoo.com and i will check into this.

  10. MJ WebWorx
    Member
    Posted 1 year ago #

    same problem here, just wasted 2 hours to find out what is causing this troubles.. won't use the plugin anymore. (fyi: i also use wp3 menus with theme location) ...

  11. neostead
    Member
    Posted 1 year ago #

    Same problem. Using RT Theme 11. Menu disappears upon activating plugin. Checked all items in thread with no fix.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic