WordPress.org

Ready to get started?Download WordPress

Forums

Post Thumbnail Editor
[resolved] Drag to select thumbnail size - thumb proportions no longer working (6 posts)

  1. offthepage
    Member
    Posted 2 years ago #

    Hi,

    Thumbnail editor is no longer constraining proportions correctly - instead when I go to create a thumbnail size, the drag feature moves the selection box where ever the mouse moves (rather than to the correct proportions I'm trying to create).

    I've tried reinstalling the plugin. And there are no other plugins recently installed that would have caused the issue (have tried deactivating all to see if they were clashing).

    Any thoughts on why this might be happening?

    Thanks so much!

    http://wordpress.org/extend/plugins/post-thumbnail-editor/

  2. offthepage
    Member
    Posted 2 years ago #

    Sorry - should have included this with my initial message.

    20120717 03:54:27 - [string] ===== STARTUP PHP MESSAGES =====
    20120717 03:54:27 - [string] ===== SERVER LOG =====
    20120717 03:54:27 - [string] [DEBUG] - PARAMETERS: Array
    (
    [action] => pte_ajax
    [pte-action] => launch
    [id] => 1093
    [em_ajax] => 1
    )

    20120717 03:54:27 - [string] [WARNING] - Couldn't find or generate metadata for image: 1093-large
    20120717 03:54:27 - [string] [WARNING] - Couldn't find or generate metadata for image: 1093-featured-thumb
    20120717 03:54:27 - [string] [WARNING] - Couldn't find or generate metadata for image: 1093-full-featured-thumb
    20120717 03:54:27 - [string] [DEBUG] - USER-AGENT: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11
    20120717 03:54:27 - [string] [DEBUG] - WORDPRESS: 3.3.2
    20120717 03:54:27 - [string] [DEBUG] - SIZER: 0.65040650
    20120717 03:54:27 - [string] [DEBUG] - META: Array
    (
    [width] => 615
    [height] => 479
    [hwstring_small] => height='96' width='123'
    [file] => 2012/07/Recall.png
    [sizes] => Array
    (
    [thumbnail] => Array
    (
    [file] => Recall-150x150.png
    [width] => 150
    [height] => 150
    )

    [medium] => Array
    (
    [file] => Recall-300x233.png
    [width] => 300
    [height] => 233
    )

    [touch-carousel-thumb] => Array
    (
    [file] => Recall-346x270.png
    [width] => 346
    [height] => 270
    )

    [carousel-thumb] => Array
    (
    [file] => Recall-115x90.png
    [width] => 115
    [height] => 90
    )

    [big-post-thumb] => Array
    (
    [file] => Recall-192x150.png
    [width] => 192
    [height] => 150
    )

    [small-post-thumb] => Array
    (
    [file] => Recall-75x58.png
    [width] => 75
    [height] => 58
    )

    [related-thumb] => Array
    (
    [file] => Recall-115x90.png
    [width] => 115
    [height] => 90
    )

    [big-nivo-thumb] => Array
    (
    [file] => Recall-513x400.png
    [width] => 513
    [height] => 400
    )

    [small-nivo-thumb] => Array
    (
    [file] => Recall-620x376.png
    [width] => 620
    [height] => 376
    )

    [blog1-thumb] => Array
    (
    [file] => Recall-205x160.png
    [width] => 205
    [height] => 160
    )

    [gallery-image] => Array
    (
    [file] => Recall-140x109.png
    [width] => 140
    [height] => 109
    )

    [portfolio1-thumb] => Array
    (
    [file] => Recall-231x180.png
    [width] => 231
    [height] => 180
    )

    [portfolio2-thumb] => Array
    (
    [file] => Recall-166x130.png
    [width] => 166
    [height] => 130
    )

    )

    [image_meta] => Array
    (
    [aperture] => 0
    [credit] =>
    [camera] =>
    [caption] =>
    [created_timestamp] => 0
    [copyright] =>
    [focal_length] => 0
    [iso] => 0
    [shutter_speed] => 0
    [title] =>
    )

    )

    20120717 03:54:29 - [string] ===== REFLOW =====
    20120717 03:54:29 - [string] ===== FIXING THICKBOX =====
    20120717 03:54:29 - [string] WINDOW WIDTH: 779
    20120717 03:55:27 - [string] ===== SETTING ASPECTRATIO: null =====

  3. sewpafly
    Member
    Plugin Author

    Posted 2 years ago #

    The line in the debug that says setting aspectratio to null is the problem, it should have a ratio specified there if the thumbnail you've selected is set to "crop". However, I can see from the debug log that none of the thumbnails that are defined have the "crop" option enabled. To see if you can get this work, Check the box, "Crop thumbnail to exact dimensions (normally thumbnails are proportional)" in Settings -> Media, and then try to crop only the "thumbnail" thumbnail.

  4. offthepage
    Member
    Posted 2 years ago #

    Great - thanks, this box was already ticked in settings->Media.

    Attempted to crop the thumbnail 150x150 and it worked fine. Seems this is the only dimension working.

    Any ideas on how to get the other image/thumb sizes working again?

  5. sewpafly
    Member
    Plugin Author

    Posted 2 years ago #

    I don't think that you can for medium and large, But for other post thumbnails you have to modify the definition.

    <?php add_image_size( $name, $width, $height, $crop ); ?>

    See this page for more information.

  6. memelab
    Member
    Posted 1 year ago #

    you can force cropping of medium by adding this code in your functions.php:

    if( false === get_option( "medium_crop" ))
        add_option("medium_crop", "1");
    else
        update_option("medium_crop", "1");

    I can't tell at a glance if this works for large, too

    tx for the plugin

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic