WordPress.org

Ready to get started?Download WordPress

Forums

Post Thumbnail Editor
Broken after upgrade to wordpress 3.3 (6 posts)

  1. David Radovanovic
    Member
    Posted 2 years ago #

    Here are the errors:

    We noticed some potential issues: Enable debugging for additional information
    
        [WARNING] - Couldn't find or generate metadata for image: 3044-0
        [ERROR] - Resize path invalid: /home/whatsthe/webapps/wtbi/wp-content/uploads/ptetmp/3044/SONNY-STITT-Jazz-0x0.jpg
        [ERROR] - Error writing image: 0 to '/home/whatsthe/webapps/wtbi/wp-content/uploads/ptetmp/3044/SONNY-STITT-Jazz-0x0.jpg'
        [WARNING] - Buffered output: <br /> <b>Warning</b>: imagecreatetruecolor() [<a href='function.imagecreatetruecolor'>function.imagecreatetruecolor</a>]: Invalid image dimensions in <b>/home/whatsthe/webapps/wtbi/wp-includes/media.php</b> on line <b>1010</b><br /> <br /> <b>Warning</b>: imagecopyresampled(): supplied argument is not a valid Image resource in <b>/home/whatsthe/webapps/wtbi/wp-content/plugins/post-thumbnail-editor/php/functions.php</b> on line <b>375</b><br /> <br /> <b>Warning</b>: imagejpeg(): supplied argument is not a valid Image resource in <b>/home/whatsthe/webapps/wtbi/wp-content/plugins/post-thumbnail-editor/php/functions.php</b> on line <b>412</b><br />

    I tried implementing "debug mode though when selected it only returns me to plugin's configuration page.

    http://wordpress.org/extend/plugins/post-thumbnail-editor/

  2. sewpafly
    Member
    Plugin Author

    Posted 2 years ago #

    Look here for some instructions about setting the debug mode.

    Does that help?

  3. David Radovanovic
    Member
    Posted 2 years ago #

    Thanks for a very usefully plugin. Well, I wish it was clearer (to me) though the debug log restates the above errors. Thinking that it was a permissions issue I manually chmod -R 777 ./* in the /home/whatsthe/webapps/wtbi/wp-content/uploads/ptetmp/3044/ and it still complains that the path is invalid. Any advice?

  4. petehobo
    Member
    Posted 2 years ago #

    I'm seeing the same thing. I suspect the path's a red herring - note the file it's trying to create ends 0x0.jpg.

    In my particular case, I've got a custom image size:
    add_image_size( 'curator-thumbnail', 300, 0 );

    Note that I'm only specifying a maximum width.

    If the new thumbnail is wider than it is high, it gets created OK. If it's higher than it is wide, I get the error.

  5. petehobo
    Member
    Posted 2 years ago #

    Looks like a change to pte_get_width_height in plugins/post-thumbnail-editor/php/functions.php has solved it for me. I changed:

    // Crop isn't set so the height / width should be based on the biggest side
    	else if ($w > $h){

    to

    // Crop isn't set so the height / width should be based on the biggest side
    	else if ($w > $h || $size_information['height'] == 0 ){

    Hope that helps.

  6. sewpafly
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks petehobo, I'm going to check in that change!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic