WordPress.org

Ready to get started?Download WordPress

Forums

Post Ratings
[resolved] Plugin not running (7 posts)

  1. viva.mundo
    Member
    Posted 2 years ago #

    I installed the plugin, first error that occurs is:
    Fatal error: Class 'Atom' not found
    Checked developers forum about this, found out he is using Atom Themes, what if you don't use his themes, can this plugin still interact with your wordpress?
    Anyhow, I commented that part out of the plugin as mentioned in the developer forum. Ratings showed up but you cannot rate because of a jQuery Error related to the missing Atom-Framework.
    How can I implement Atom into my own Theme?
    I'm using the newest WP and Plugin files.

    http://wordpress.org/extend/plugins/post-ratings/

  2. houseofstrauss
    Member
    Posted 2 years ago #

    same problem, what's the resolution?

  3. viva.mundo
    Member
    Posted 2 years ago #

    Nice not be alone with this problem?

  4. houseofstrauss
    Member
    Posted 2 years ago #

    Ye, even better if someone could fix it eh? I moved on to a different plugin, but I wanted to use this one because it looks like it's a no-bloat piece of coding. Some of those other polls and voting plugins are very heavy.

  5. digitalnature
    Member
    Plugin Author

    Posted 2 years ago #

    This should be now fixed in 2.2

    Apparently some PHP versions throw this fatal error when checking if a class constant exists, and the class is missing (instead of just returning "false").

  6. houseofstrauss
    Member
    Posted 2 years ago #

    OK! Many thanks for attending to that.

  7. viva.mundo
    Member
    Posted 2 years ago #

    Yes, thanks a lot it works!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic