WordPress.org

Ready to get started?Download WordPress

Forums

Post From Site
Get Rid of Ugly post confirmed Refirect. (8 posts)

  1. enderpal444
    Member
    Posted 2 years ago #

    Anyone know how to get rid of the redirect to this plane white page tha shows some crude text confirming a post submission. This plugin is great other than that.

    http://wordpress.org/extend/plugins/post-from-site/

  2. Kelly Dwan
    Member
    Plugin Author

    Posted 2 years ago #

    Hello

    The plugin shouldn't be redirecting to a new page, there's probably something wrong with the way it's trying to include the javascript on your site. If you give me your URL, I can take a look and see what the issue might be.

    --Kelly

  3. enderpal444
    Member
    Posted 2 years ago #

    I fixed this issue by adding a redirect in the pfs-submit.php and that did the trick. The problem now is that after the update all posts are posted ad "drafts" even with the setting to "publish".

  4. advbait
    Member
    Posted 2 years ago #

    Hi, enderpal444 tell where the correct code.

  5. enderpal444
    Member
    Posted 2 years ago #

    @advbait The post redirect was added on line 127. Here's the working script.

    http://pastebin.com/3zhKabeG

  6. Kelly Dwan
    Member
    Plugin Author

    Posted 2 years ago #

    enderpal444, the script you linked to is from an old version of PFS - the new version changed the setting names somewhat. Your revised script is looking for the old settings, which is why changing the post status isn't changing anything.

  7. enderpal444
    Member
    Posted 2 years ago #

    I updated the plugin but one thing I found is it doesnt allow contrubutors to submit a post. You have to be author or higher and I'd like to be able to approve each post first. What I'm really looking for is a way to change a role to author after 2 posts are approved.

  8. MPu2012
    Member
    Posted 2 years ago #

    Some strange behavior with this plug-in. I created site and used this plug-in. At some point of time noticed that plug-in is broken. Was not able to fix it, thus created clean WordPress deployment. Plug-in worked fine with this clean deployment. Again, something broke the plug-in and it started to show this ugly post confirmed. I fixed it by adding a redirect as proposed earlier in this discussion. This is just as information that something is wrong with plug-in. My educated guess is that it is somethign related to permalinks. I changed setting at some point, but did not remember to try this plug-in immediately after this, thus cannot confirm my statement.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic