WordPress.org

Ready to get started?Download WordPress

Forums

Post Expirator
1.6.1 not working (11 posts)

  1. kryvulena
    Member
    Posted 1 year ago #

    Hi

    I tried the plugin v1.6.1 with 2 separate WP instances v3.4.2 with all plugins disabled to ensure they don't affect the post expirator. It does not work on any instance I tried with.
    I guess the issue regards the cron. I checked my ISP's spec and here are their cron requirements (apologies for Google-trans):

    =========

    Introduction

    Recurring scripting "Cron" is based on the programmed call appropriately named script, located in the root directory of your server in home.pl.

    Time to execute a script can be strictly defined by time:
    every five minutes,
    hour (hourly)
    daily (daily)
    every week (weekly)
    each month (monthly)
    a strictly specified time (accurate to 5 minutes).
    What are the file extensions I use the CRON function?

    Available upgrades for the CRON function is:
    . Php
    . Php5
    . En
    . Cgi
    . Py

    To use the CRON home.pl on the server?

    To use the solution to the root account, put the script with the name of principle:

    cron [hourly | daily | monthly | weekly]. [extension]

    The exact hour of starts:
    hourly - full hours *: 00,
    daily - every day at 1:15,
    weekly - on Saturday at 1:30,
    monthly-first of each month at 1:45.
    For example, the file "cron-daily.php" will run every day at 1:15, using the PHP interpreter.
    IMPORTANT! You can not call script periodically with. Php3
    Other examples of the use of CRON function:

    cron-[Time]. [extension]
    File "cron-13.php" runs every day at 13:00 by PHP.
    File "cron-04.php" starts at 04:00 by PHP.
    cron-[hhmm]. [extension]
    File "cron-1545.php" will be performed daily at 15:45.
    Maximum precision is 5 minutes - for example, will not work file called "cron-1546.php".

    cron-[xx] minutes. [extension] - where xx is the minute. Allowed values ​​are - 5, 10, 15, 20, 30
    File "cron-5min.php" will be performed every 5 minutes, starting with the publication of a file in the root directory of the server home.pl.
    Good to know

    Environment that causes recurring scripting is identical to the environment in which the scripts are run on virtual servers. In practice, this means that calling such a little different from the usual call after HTTP GET.

    In order to protect yourself before calling cron file by any user, block access to it in the file. "Htaccess". You can do this by typing in the contents of the file. "Htaccess" the following code:
    : Location / cron-daily.php
    Access deny all
    File ". Htaccess" with content that will block calls CRON file should be placed in the root directory of the server. In the line that starts with the phrase ": Location" CRON define the file name to be locked before calling.

    =========

    I used 1-hour option (not the 1-min interval, which is incompatible with my server. Is there anything I could do to fix it?

    http://wordpress.org/extend/plugins/post-expirator/

  2. Aaron Axelsen
    Member
    Plugin Author

    Posted 1 year ago #

    WordPress should automatically take care of the cron for you. The info you have there seems to be for system cron, and very old

  3. kryvulena
    Member
    Posted 1 year ago #

    Thanks for fast reply.

    Ok then. But there's something wrong anyway. Is there a way I could figure out what's stopping it from working?

  4. kryvulena
    Member
    Posted 1 year ago #

    I checked the diagnostics:

    Fri, 14 Sep 2012 02:40:01 +0000 expirationdate_delete hourly 3600

    Also I have green OK on the cron in the Post Expirator's options. But it appears not to be able to send posts to drafts anyway.

  5. Aaron Axelsen
    Member
    Plugin Author

    Posted 1 year ago #

    I do see you have it set to hourly - that means it will only expire posts every hour .. instead of every minute. Have you waited an hour after the set expiration time?

  6. kryvulena
    Member
    Posted 1 year ago #

    Yes I did. Nothing happened :( I also tried with them 1 min. interval on another instance - same - no result.

  7. Aaron Axelsen
    Member
    Plugin Author

    Posted 1 year ago #

    are there other plugins installed?

  8. kryvulena
    Member
    Posted 1 year ago #

    Once I installed the plugin and noticed the issue, I disabled all other plugins to see if any of them affect the Post Expirator. The issue still occurs with all plugins disabled.

  9. defe266
    Member
    Posted 1 year ago #

    I have problems too, with 3.4.1 and 3.4.2

    I removed all plugins and put the default theme. And nothing.

    Far as I can see, the problem is that "expirationdate_delete" does not change by the minute despite its set hourly.

    Tue, 18 Sep 2012 20:40:06 +0100 check_and_unstick_scheduled_posts hourly 3600
    Tue, 18 Sep 2012 21:21:41 +0100 qs_cron_hook hourly 3600
    Tue, 18 Sep 2012 21:26:32 +0100 expirationdate_delete postexpiratorminute 60
    Wed, 19 Sep 2012 02:06:38 +0100 wp_version_check twicedaily 43200
    Wed, 19 Sep 2012 02:06:38 +0100 wp_update_plugins twicedaily 43200
    Wed, 19 Sep 2012 02:06:38 +0100 wp_update_themes twicedaily 43200
    Wed, 19 Sep 2012 14:06:46 +0100 wp_scheduled_delete daily 86400
    Wed, 19 Sep 2012 15:48:29 +0100 wp_scheduled_auto_draft_delete daily 86400

  10. kryvulena
    Member
    Posted 1 year ago #

    Hi

    Following @dafe266 notes, I also deactivated my theme and used one of default WP themes = same result. It does not work for me.

  11. defe266
    Member
    Posted 1 year ago #

    dont work for me too.

    I think "expirationdate_delete" is frozen; its set "postexpiratorminute" but doesnt change by the minute.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.