WordPress.org

Ready to get started?Download WordPress

Forums

Portable phpMyAdmin
[resolved] Probably reason of this is that you did not create configuration file. (16 posts)

  1. BBPRESS
    Member
    Posted 2 years ago #

    The first time I installed it with 3.4.1, it worked;
    the second time, after delete my WP website database(to clean up my db), and reinstall WP with a new package downloaded from wordpress.org, the latest 3.4.1, it did NOT work.

    The error messages are pasted below.

    Probably reason of this is that you did not create configuration file. You might want to use setup script to create one.
    ---> this "setup script" lead to my website in a iframe, did not solve anything.

    Error
    MySQL said: #1045 - Access denied for user 'root'@'localhost' (using password: NO)
    ---> I have no idea what it said, I can access the other phpmyadmin in my website host's control panel.

    http://wordpress.org/extend/plugins/portable-phpmyadmin/

  2. AboutWeb
    Member
    Posted 2 years ago #

    I have the same problem as you. This started after I updated the plugin.

  3. BBPRESS
    Member
    Posted 2 years ago #

    I have tested it locally, it worked, but I dont know why.

    I also tried reinstall the portable phpmyadmin, but it never work ever since I install it with a new database.

    Chouby? Any idea?

  4. Ciprian Popescu
    Member
    Plugin Author

    Posted 2 years ago #

    I'm working on this. It's an issue with the updated phpMyAdmin internal version.

  5. BBPRESS
    Member
    Posted 2 years ago #

    Hi Ciprian

    I have just updated the portable pma pplugin, but I get another error,
    error message pasted below:

    Fatal error: Call to a member function add_query_var() on a non-object in /home/mockupusername/public_html/mockupwebsitename.com/wp-content/plugins/wordpress-seo/inc/class-sitemaps.php on line 82

    Is it something to do with yoast's SEO?

    Thanks

  6. BBPRESS
    Member
    Posted 2 years ago #

    Well bad news, it does conflict with yoast's SEO plugin... (or the other way around)

    How can I fix this?

    I really would like to use both of my favorite plugin at the same time!

    I love the simplicity of portable pma that allow me to see my database right away.

    Best,
    BB

  7. AboutWeb
    Member
    Posted 2 years ago #

    I got another error:
    "Sorry, WassUp requires WordPress 2.2 or higher to work."
    I do have a plugin for stats, called WassUp, but it works with no problems, I don't know why PMA says about WassUp...and my WordPress is the latest version, everything updated.

  8. Ciprian Popescu
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for reporting this, I'll look at both the errors and the conflicts.

  9. BBPRESS
    Member
    Posted 2 years ago #

    Thanks for replying Ciprian, hope to hear from you soon as the update fix the issue!

    Horray for the PMA

  10. Ciprian Popescu
    Member
    Plugin Author

    Posted 2 years ago #

    Version 1.2.9.5 fixes most of the errors. Please confirm!

  11. AboutWeb
    Member
    Posted 2 years ago #

    For me not. Still the same error: "Sorry, WassUp requires WordPress 2.2 or higher to work."

  12. BBPRESS
    Member
    Posted 2 years ago #

    Fatal error: Call to a member function add_query_var() on a non-object in /home/username/public_html/mywebiste.com/wp-content/plugins/wordpress-seo/inc/class-sitemaps.php on line 82

    Another error after update!

  13. João Gil Garcia
    Member
    Posted 2 years ago #

    Same error -

    Fatal error: Call to a member function add_query_var() on a non-object in /home/***/public_html/***.***/wp-content/plugins/wordpress-seo/inc/class-sitemaps.php on line 82

    Thanks for your time.

  14. Harsh Agrawal
    Member
    Posted 1 year ago #

    Getting the same error..Seems like WordPress SEO compatibility issue. Though not sure..
    wp-content/plugins/wordpress-seo/inc/wpseo-functions.php on line 321

  15. levelfourdevelopment
    Member
    Posted 1 year ago #

    I'm getting this error when I use the plugin as well, this is all current stuff to, with 3.5.1 and current plugin. My site works ok, but I"m using an amfphp install to access some services and somehow this is getting in there and throwing this error? deactivate plugin, and amfphp works fine.

    wpseo-functions.php</b> on line <b>321

  16. levelfourdevelopment
    Member
    Posted 1 year ago #

    as a side note, it will work enabled and activated, but I have to disable the XML sitemap feature to stop throwing this error.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic