WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Polylang] zh_CN post gives 404 error (5 posts)

  1. lgromanowski
    Member
    Posted 1 year ago #

    Hi,
    at first big thank you for a great plugin! :)

    I'm running https://openmw.org/ site and one of our users is trying to do some translations in Chinese language (zh_CN). The post is written and all things related to language are set-up in similar fashion like we do with other languages but it gives us 404 error:
    https://openmw.org/zh/

    Direct link to post is working:
    https://openmw.org/2012/12/17/%E6%9C%AC%E5%91%A8%E5%9B%9E%E9%A1%BE-2012-12-08-ap0/

    Our polylang settings are here:
    http://i.imgur.com/pBkS2.jpg?1

    Would you help us with this, please?

    If you need any other details please let me know.

    Best regards,
    Lukasz

  2. Chouby
    Member
    Posted 1 year ago #

    Could you go in settings->permalinks and click on "save changes"?

  3. lgromanowski
    Member
    Posted 1 year ago #

    Wow, "save changes" fixes the issue and everything is working now (btw. was that needed because WP 3.5 update, or is there other reason for saving changes in permalink section?), thank you :D

  4. Chouby
    Member
    Posted 1 year ago #

    It has nothing to do with 3.5. Polylang should automatically do this when adding/deleting a language but a bug introduced in v0.9.2 (that nobody noticed until now!) prevents this to work correctly. It will corrected in the next release.

  5. alexmaier
    Member
    Posted 1 year ago #

    Yes! Quiet important hint ... thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic