WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
Problem with menu on the blog and some advise (3 posts)

  1. anarodrigues
    Member
    Posted 2 years ago #

    Hello, first of all thank you for this plug-in, it is really helpfull but I have some problems:

    I am trying to create a portfolio website in two languages (portuguese and english) but the blog itself doesn't need translated posts because it fits both languages. So the polylang plug-in, for me, would be really usefull because of the menu and the pages.

    That's what i did first and it worked just fine but then I had many issues. When I created a page for english and portuguese everything matched and the menu worked aswell BUT then i had the blog issue.

    I want the website to start on a static page so I created a page http://www.mysite.com/blog for the blog and since the posts that I imported fit both languages I thought of linking it on the menu as a personalized link on the menus. So in the portuguese or english menu the link for the blog would be http://www.mysite.com/blog
    Two problems:
    - Obviously the blog would assume the default language i would choose (this case english)
    - For some reason that I don't understand, I can't add personalized links to the portuguese menu. It works on the english, but not in the portuguese (maybe it's some issue with the theme but I don't believe so).

    SO, I'm lost... The plug-in is great but for me it would work perfectly if I had started the website from scratch... the blog that I have is since 2008, too extensive and already titled and written to fit both languages so I won't change it... but I can't add a menu to it on the header :(

    I need some advise. If there anyway around this, or I should have two wordpress installs and even if that's the proper solution for me, how could I make a two language menu on the blog? :(

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    For menus, can you check these two links:
    http://wordpress.org/support/topic/plugin-polylang-multilingual-menus-1?replies=4
    http://wordpress.org/support/topic/plugin-polylang-menu-for-a-theme-does-not-change-language?replies=21

    For your posts, maybe you are a candidate to test the v0.9
    http://wordpress.org/support/topic/development-of-polylang-v09
    together with this experimental plugin: http://pastebin.com/bsEM0P2R
    Please consider this *under development* and don't play with your production site.

    Edit: could you tell me if the development version 0.9dev35 solves the menu issue?

  3. anarodrigues
    Member
    Posted 2 years ago #

    Hello Chouby, thank you for your fast reply! I'm going to test it as soon as I arrive to my personal computer where I have all the files and I'll let you know if it solves the menu issue!

    Once again thank you and congrats for all your work :D

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic