WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
langauge root redirects to a different page (same language) (7 posts)

  1. disconnect
    Member
    Posted 2 years ago #

    In my site, I have EN, IT, DE and ES.

    site/de/ for example redirects to a different page (not DE root!) in 302

    same in all languages. site/language/ redirects to a page that is not a translation of the EN root (site/)

    Also tried rollback to version 0.8.6, didn't work

    Maybe the only solution is to reinstall wordpress & the plugins?

    Is there a way to uninstall + reinstall and then create the connections again?

    Please advise

    Thanks!

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    Could you be clearer on the description of your problem ?
    What are your Polylang settings ?
    What is your permalink structure ?
    Is your homepage a static page ?
    Maybe a link would help

  3. Sonjovski
    Member
    Posted 1 year ago #

    I have the same problem. Site is in English and Serbian.
    Problem
    I have uninstall + reinstall PolyLang, and all pages are now shown, both english and serbian... instead of just english and just serbian.

    Once I edit an english page, it only allows me to add NEW serbian page.
    but the serbian page already exists!!
    Sorry for my english, I hope I made it clear as possible :)
    It's on my wamp, sorry I can't link it :/
    So, is there a way to connect those two? I'm pretty new to WP, any help appreciated.

    Polylang settings

    Permalink structure: Post name //localhost/wordpress/sample-post/

    yes my home page is a static page.

  4. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    @sonjovski, you wrote "I have uninstall + reinstall PolyLang". how did you do? did you click on the red "delete" link in the plugin list table?

  5. Sonjovski
    Member
    Posted 1 year ago #

    yes, I did... I was warned of the loss, but I've read somewhere else it solved the problem. Seems like I need to make new pages, because there is no other option?

  6. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Well, by doing so, Polylang removes every data it has created.

    No you don't need to make new pages. You can use the existing ones. But you have to redefine the languages for all pages and recreate the links between pages for translations.

    Edit the page in one language, for example English. Look at the url which is something like:
    http:/yoursite/wp-admin/post.php?post=15&action=edit
    Here '15' is the page id of the English page. Set the correct language.

    Then, edit the same page for example in italian. Set the correct language, enter '15' as page id in front of English and then save changes. Do the same for other translations.

    It may be important to redefine the language of categories and post tags before you define the language of posts and pages.

  7. Sonjovski
    Member
    Posted 1 year ago #

    Oh thanks, I was trying to find pages' IDs, but I forgot to look in the adress bar >.< thank you very much, and btw, maybe it's be useful to add new option in next plugin update:
    to have "add existing page" next to "new page" option :)

    and TY for such a quick response!! ;)

    wish you all the best,
    Sonja

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic