WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] Images and most recent version of PolyLang (11 posts)

  1. Matt Rad
    Member
    Posted 1 year ago #

    Hi,
    I recently upgraded to the new version of PolyLang, and the media viewer is not playing nice with it. I can see that my media files exist, but cannot insert images etc in to post and pages.

    Basically, I am having this issue:

    In my wordpress installation, I have recently run into a problem - I can't access my media files.
    When I go to the Media Library, I should see several files I've uploaded since I started this site; Instead I see the text "No Media Attachments Found." And seeing as the images I uploaded still are showing up on the site, and above the error message it still lists "All (19)" etc, I think they're still there.

    Deactivating PolyLang results in the Media Viewer working correctly again.

    Is anyone else having the same issue?

    Cheers.

    http://wordpress.org/extend/plugins/polylang/

  2. Matt Rad
    Member
    Posted 1 year ago #

    Reinstalling 0.8.10 resolves the issue.

  3. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Now Polylang v0.9 does support languages and translations for media. When you want to insert a media from the library, you should see only media which have the same language of your post. If you did no set any language for media, it is normal that you see nothing.

  4. Matt Rad
    Member
    Posted 1 year ago #

    Great! Thanks, that makes perfect sense. It's a great plug-in.

  5. kkarpieszuk
    Member
    Posted 1 year ago #

    Hello @Chouby

    i understand why you did this modification - this is good idea for websites which has some image-banners with different languages - but i also think that you forgot about websites which already are running your plugin and has tens of thousands images in media :) setting language for them will take me weeks :)

    Do you know how automatically set all languages to all media in blog?

    fast workaround is - according to your documentation - to define PLL_MEDIA_SUPPORT false value in wp-config.php and i did it and it works. But as i mentioned in the top of this post, i love your idea to add media support and i want to use it :) But setting manualy language for 12000 pictures is not an option :(

    Any help will be great

  6. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    As soon as you have some content without a language, the option "There are posts, pages, categories or tags without language set. Do you want to set them all to default language ?" should appear in red in your language settings. It should work for media too. There is however no quick way to create translations.

    But if you don't use multilingual captions and descriptions, it is probably better to use the PLL_MEDIA_SUPPORT option (I plan to transfer it to user interface in 1.0)

  7. Sandro Bilbeisi
    Member
    Posted 1 year ago #

    You should allow media with no language assigned to always be returned.

  8. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    I guess you mean that I should keep media translations and allow media without languages in the same time. This is however not at all easy. I am currently working on something similar for posts on frontend: http://wordpress.org/support/topic/plugin-polylang-all-languages-option-for-posts-and-pages (still experimental and buggy).

    For now, you have to choose between the old situation (by setting PLL_MEDIA_SUPPORT to false) and the new feature as it is proposed in v0.9.

  9. tntdynamight
    Member
    Posted 1 year ago #

    Hi!

    Thanks for a great plugin! I just run into one problem:
    I need the pictures available without filling their translation info manually every time. I have tried setting PLL_MEDIA_SUPPORT to false in wp-config.php , but It still doesn't show me any media for english (default being german) pages to insert.
    I run WordPress 3.5.1 and have tried polylang 1.0.4 stable and 1.1dev10, neither giving me the media.
    In the media panel, I still get columns for the languags, and if manually translating the picture appears to be added in 'insert media'.

    I had suspected that my wp-config option is ignored, but it's the right file, and I just add
    define(PLL_MEDIA_SUPPORT, false);

    before the
    /* That's all ... */ line.

    Any Ideas what could still be going wrong?

  10. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    This topic is too old and Polylang has changed a bit since that time. The option is now integrated in Polylang settings. Look at the option "Activate languages and translations for media"

  11. tntdynamight
    Member
    Posted 1 year ago #

    I have no idea how I overlooked that option,
    thank you very much, works great.
    Love your plugin!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic